Bug 134922 - gnuplot should BuildRequires: texinfo readline-devel
Summary: gnuplot should BuildRequires: texinfo readline-devel
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnuplot   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: FE-Legal FC3Target
TreeView+ depends on / blocked
 
Reported: 2004-10-07 09:55 UTC by Maxim Dziumanenko
Modified: 2015-03-05 01:14 UTC (History)
2 users (show)

Fixed In Version: 4.0.0-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 19:13:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Maxim Dziumanenko 2004-10-07 09:55:11 UTC
Description of problem:
makeinfo from texinfo package needed to build gnuplot
readline-devel is required because of --with-readline=gnu option to
%configure

Version-Release number of selected component (if applicable):
gnuplot-4.0.0-3

How reproducible:
Always

Steps to Reproduce:
1.rpm -e texinfo
2.rpmbuild -ba gnuplot-4.0.0-3
3.Wait for build error
  
Actual results:


Expected results:


Additional info:

Comment 1 Tim Waugh 2004-10-11 14:07:25 UTC
Fix built as 4.0.0-4.

Comment 2 Axel Thimm 2007-08-05 16:08:24 UTC
Doesn't linking gnuplot against readline result in a non-redistributable binary?
E.g. gnuplot in Fedora violates the GPL.

Comment 3 Axel Thimm 2007-08-05 16:12:39 UTC
A legal alternative to readline is libedit - already part of Fedora.

Comment 4 Tom "spot" Callaway 2008-01-15 19:13:21 UTC
Looking at gnuplot:

The package is actually licensed under a dual license, gnuplot and GPLv2+, since
the src/wxterminal/* files are dual licensed. Since readline is GPLv2+, this is
compatible.

If we were to disable the wx functionality, we might be in a pickle, but as is,
we're ok.




Note You need to log in before you can comment on or make changes to this bug.