Bug 891229

Summary: nodejs-request - Simplified HTTP request client
Product: [Fedora] Fedora Reporter: T.C. Hollingsworth <tchollingsworth>
Component: Package ReviewAssignee: Miro Hrončok <mhroncok>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: mhroncok, misc, notting, package-review
Target Milestone: ---Keywords: Reopened
Target Release: ---Flags: mhroncok: fedora‑review+
limburgher: fedora‑cvs+
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-15 21:38:12 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 891189, 891203, 903762    
Bug Blocks: 891171, 891175, 891186, 891215    

Description T.C. Hollingsworth 2013-01-02 04:17:55 EST
Spec: http://patches.fedorapeople.org/npm/nodejs-request.spec
SRPM: http://patches.fedorapeople.org/npm/nodejs-request-2.12.0-1.src.rpm
Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4831097
FAS username: patches

Simplified HTTP request client.

This package is part of the npm stack and a future F19 Feature for Node.js.

This package may depend on other packages in the npm stack that aren't explicitly
listed as dependencies of this bug.  For more information, see bug 891171.

Please use nodejs-0.6.5-3 or later when building or using this package.
Comment 1 T.C. Hollingsworth 2013-01-10 02:52:19 EST
Updated with empty %build sections and other issues found in various reviews.

Spec: http://patches.fedorapeople.org/npm/nodejs-request.spec
SRPM: http://patches.fedorapeople.org/npm/nodejs-request-2.12.0-2.src.rpm
Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4854382
Comment 2 Miro Hrončok 2013-01-11 13:45:31 EST
Summary and Description OK.

MUST: rpmlint must be run on the source rpm and all binary rpms the build produces. The output should be posted in the review.

$ rpmlint ../SRPMS/nodejs-request-2.12.0-2.src.rpm ../RPMS/noarch/nodejs-request-2.12.0-2.noarch.rpm
nodejs-request.noarch: W: only-non-binary-in-usr-lib
nodejs-request.noarch: W: dangling-symlink /usr/lib/node_modules/request/node_modules/form-data /usr/lib/node_modules/form-data
nodejs-request.noarch: W: dangling-symlink /usr/lib/node_modules/request/node_modules/mime /usr/lib/node_modules/mime
2 packages and 0 specfiles checked; 0 errors, 3 warnings.

Symlinks OK, package requires npm(form-data) and npm(mime)
False positive.

MUST: The package must be named according to the Package Naming Guidelines. OK
MUST: The spec file name must match the base package %{name}, in the format %{name}.spec unless your package has an exemption. OK
MUST: The package must meet the Packaging Guidelines. OK
MUST: The package must be licensed with a Fedora approved license and meet the Licensing Guidelines. OK

MUST: The License field in the package spec file must match the actual license.

License chcecked in LICENSE file: ASL 2.0. OK
License chcecked in vendor/cookie/*: MIT. OK

MUST: If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package must be included in %doc. OK
MUST: The spec file must be written in American English. OK
MUST: The spec file for the package MUST be legible. OK
MUST: The sources used to build the package must match the upstream source, as provided in the spec URL. Reviewers should use sha256sum for this task as it is used by the sources file once imported into git.

$ sha256sum ../SOURCES/request-2.12.0.tgz 
a26790d2179da11a644d5deaa2ae5d37472bf0e73355fde02ea5923106308997  ../SOURCES/request-2.12.0.tgz
$ spectool -g nodejs-request.spec 
Getting http://registry.npmjs.org/request/-/request-2.12.0.tgz to ./request-2.12.0.tgz
$ sha256sum request-2.12.0.tgz 
a26790d2179da11a644d5deaa2ae5d37472bf0e73355fde02ea5923106308997  request-2.12.0.tgz

OK

MUST: The package MUST successfully compile and build into binary rpms on at least one primary architecture. OK
MUST: All build dependencies must be listed in BuildRequires, except for any that are listed in the exceptions section of the Packaging Guidelines ; inclusion of those as BuildRequires is optional. Apply common sense. OK, builds in mock
MUST: Packages must NOT bundle copies of system libraries.

FIX: The MIT licensed part in vendor/cookie seems like a bundling of https://github.com/LearnBoost/tobi/tree/master/lib/cookie
However, I might be wrong, so please correct me, if I am. It's not like I want to make this scope even bigger, just for fun ;)

MUST: A package must own all directories that it creates. If it does not create a directory that it uses, then it should require a package which does create that directory. OK
MUST: A Fedora package must not list a file more than once in the spec file's %files listings. OK
MUST: Permissions on files must be set properly.

$ rpm -q -lv -p ../RPMS/noarch/nodejs-request-2.12.0-2.noarch.rpm 
drwxr-xr-x    2 root    root                        0 led 11 19:25 /usr/lib/node_modules/request
-rw-r--r--    1 root    root                     3591 lis  9 22:48 /usr/lib/node_modules/request/aws.js
-rw-r--r--    1 root    root                     3346 lis  9 22:48 /usr/lib/node_modules/request/forever.js
-rw-r--r--    1 root    root                    33675 lis  9 22:48 /usr/lib/node_modules/request/main.js
drwxr-xr-x    2 root    root                        0 led 11 19:25 /usr/lib/node_modules/request/node_modules
lrwxrwxrwx    1 root    root                       31 led 11 19:25 /usr/lib/node_modules/request/node_modules/form-data -> /usr/lib/node_modules/form-data
lrwxrwxrwx    1 root    root                       26 led 11 19:25 /usr/lib/node_modules/request/node_modules/mime -> /usr/lib/node_modules/mime
-rw-r--r--    1 root    root                     1086 lis  9 22:48 /usr/lib/node_modules/request/oauth.js
-rw-r--r--    1 root    root                      563 lis  9 22:50 /usr/lib/node_modules/request/package.json
-rw-r--r--    1 root    root                     6403 lis  9 22:48 /usr/lib/node_modules/request/tunnel.js
-rw-r--r--    1 root    root                      627 lis  9 22:48 /usr/lib/node_modules/request/uuid.js
drwxr-xr-x    2 root    root                        0 led 11 19:25 /usr/lib/node_modules/request/vendor
drwxr-xr-x    2 root    root                        0 led 11 19:25 /usr/lib/node_modules/request/vendor/cookie
-rw-r--r--    1 root    root                     1272 bře 23  2012 /usr/lib/node_modules/request/vendor/cookie/index.js
-rw-r--r--    1 root    root                     1447 lis 15  2011 /usr/lib/node_modules/request/vendor/cookie/jar.js
drwxr-xr-x    2 root    root                        0 led 11 19:25 /usr/share/doc/nodejs-request-2.12.0
-rw-r--r--    1 root    root                     9140 led 27  2011 /usr/share/doc/nodejs-request-2.12.0/LICENSE
-rw-r--r--    1 root    root                    10432 říj 28 18:30 /usr/share/doc/nodejs-request-2.12.0/README.md

OK

MUST: Each package must consistently use macros. OK
MUST: The package must contain code, or permissable content. OK
MUST: If a package includes something as %doc, it must not affect the runtime of the application. OK
MUST: Packages must not own files or directories already owned by other packages. OK
MUST: All filenames in rpm packages must be valid UTF-8. OK

SHOULD: The reviewer should test that the package builds in mock. OK
SHOULD: If the package has file dependencies outside of /etc, /bin, /sbin, /usr/bin, or /usr/sbin consider requiring the package which provides the file instead of the file itself. OK

TODO: Please consider running tests when dependencies are ready for Fedora.

Resolution: NEEDSWORK.

Basically, the only problem is the bundling.
Comment 3 T.C. Hollingsworth 2013-01-11 15:06:00 EST
(In reply to comment #2)
> FIX: The MIT licensed part in vendor/cookie seems like a bundling of
> https://github.com/LearnBoost/tobi/tree/master/lib/cookie
> However, I might be wrong, so please correct me, if I am. It's not like I
> want to make this scope even bigger, just for fun ;)

No, you're right.  I'll package tobi and patch request to require("tobi/lib/cookie") instead.
Comment 4 T.C. Hollingsworth 2013-01-15 07:19:36 EST
So, requiring tobi will create a dependency loop:
% npm install tobi >/dev/null 2&>1
% npm ls
└─┬ tobi@0.3.2
  ├── htmlparser@1.7.6
  ├─┬ jsdom@0.3.4
  │ ├── cssom@0.2.5
  │ ├── cssstyle@0.2.3
  │ ├── nwmatcher@1.3.0
  │ └─┬ request@2.12.0
  │   ├─┬ form-data@0.0.3
  │   │ ├── async@0.1.9
  │   │ └─┬ combined-stream@0.0.3
  │   │   └── delayed-stream@0.0.5
  │   └── mime@1.2.7
  ├── qs@0.5.3
  └── should@1.2.1

For added fun, there would also be a recursive symlink:
/usr/lib/(node_modules/request/node_modules/tobi/node_modules/jsdom/)*
Comment 5 Miro Hrončok 2013-01-15 09:19:51 EST
Dependency loop shouldn't be such a big problem when installing from a repository, but the recursive symlink might cause a lot of pain.

I am not sure, if this is OK or not, Mario, is there anything we should (not) do?
Comment 6 Miro Hrončok 2013-01-20 15:44:12 EST
You don't need to symlink tobi the standard way, all you need is to symlink cookie form tobi to node_modules/request/vendor/cookie/

That would avoid the loop, right?
Comment 7 T.C. Hollingsworth 2013-01-21 00:16:54 EST
I think the best way is when packaging tobi, to create a nodejs-tobi-cookie subpackage, that installs only the cookie portion of tobi as its own "tobi-cookie" node module, in %{nodejs_sitelib}/tobi-cookie.  Both tobi and request can then be patched to use that module instead.

This way, we use node's module semantics properly, and avoid both the dependency loop and symlink loop.  Also, upstream is interested in splitting off the cookie functionality, so if/when they do so it'll be easy to Obsolete this subpackage with the new module.

Sound good?
Comment 8 Miro Hrončok 2013-01-21 05:54:23 EST
Yes, sounds as a very transparent solution.
Comment 9 T.C. Hollingsworth 2013-01-24 14:57:03 EST
Okay, so while talking to Stephen Gallagher (the node engine maintainer) we realized that we don't want binary native modules in the distribution yet, since they'll require bumping for every Node.js release until 0.10 is released.  Therefore, I can only package the cookie part of it for now.  That review is in bug 903762.

This is an updated version of the request module that uses the unbundled cookie:
Spec: http://patches.fedorapeople.org/npm/nodejs-request.spec
SRPM: http://patches.fedorapeople.org/npm/nodejs-request-2.12.0-2.src.rpm
Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4900155
Comment 11 Miro Hrončok 2013-01-25 11:45:34 EST
SRPM 404 :(
Comment 12 T.C. Hollingsworth 2013-01-26 15:03:11 EST
Sorry, must have forgot to `scp` it.  The above URLs are fixed.
Comment 13 Miro Hrončok 2013-01-27 08:07:54 EST
Still cannot get it. Are you sure?
Comment 14 Michael Scherer 2013-01-27 08:24:28 EST
I confirm the 404 on the srpm ( and Miro, you have set fedora-review to + by error it seems, a new variation of the ff bug ? )
Comment 15 Michael Scherer 2013-01-27 08:25:21 EST
File name is nodejs-request-2.12.0-3.fc17.src.rpm  , notice the extra .fc17
Comment 16 Miro Hrončok 2013-01-27 13:49:37 EST
(In reply to comment #14)
> I confirm the 404 on the srpm ( and Miro, you have set fedora-review to + by
> error it seems, a new variation of the ff bug ? )
Sorry.

(In reply to comment #15)
> File name is nodejs-request-2.12.0-3.fc17.src.rpm  , notice the extra .fc17
Works.
Comment 17 Miro Hrončok 2013-01-27 13:57:13 EST
$ rpm -q -lv -p ../RPMS/noarch/nodejs-request-2.12.0-3.fc18.noarch.rpm 
drwxr-xr-x    2 root    root                        0 led 27 19:52 /usr/lib/node_modules/request
-rw-r--r--    1 root    root                     3591 lis  9 22:48 /usr/lib/node_modules/request/aws.js
-rw-r--r--    1 root    root                     3346 lis  9 22:48 /usr/lib/node_modules/request/forever.js
-rw-r--r--    1 root    root                    33675 lis  9 22:48 /usr/lib/node_modules/request/main.js
drwxr-xr-x    2 root    root                        0 led 27 19:52 /usr/lib/node_modules/request/node_modules
lrwxrwxrwx    1 root    root                       31 led 27 19:52 /usr/lib/node_modules/request/node_modules/form-data -> /usr/lib/node_modules/form-data
lrwxrwxrwx    1 root    root                       26 led 27 19:52 /usr/lib/node_modules/request/node_modules/mime -> /usr/lib/node_modules/mime
-rw-r--r--    1 root    root                     1086 lis  9 22:48 /usr/lib/node_modules/request/oauth.js
-rw-r--r--    1 root    root                      563 lis  9 22:50 /usr/lib/node_modules/request/package.json
-rw-r--r--    1 root    root                     6403 lis  9 22:48 /usr/lib/node_modules/request/tunnel.js
-rw-r--r--    1 root    root                      627 lis  9 22:48 /usr/lib/node_modules/request/uuid.js
drwxr-xr-x    2 root    root                        0 led 27 19:52 /usr/share/doc/nodejs-request-2.12.0
-rw-r--r--    1 root    root                     9140 led 27  2011 /usr/share/doc/nodejs-request-2.12.0/LICENSE
-rw-r--r--    1 root    root                    10432 říj 28 18:30 /usr/share/doc/nodejs-request-2.12.0/README.md


Shouldn't the cookie module be linked to /usr/lib/node_modules/request/node_modules/ ?

What about not adding the nodejs-tobi-cookie dependency manually, but use the %nodejs_fixdep macro? That should add the require and do the link, right?
Comment 18 Miro Hrončok 2013-01-27 16:15:05 EST
I cannot see, where you apply the patch. Am i blind, or you are not doing it?
Comment 19 T.C. Hollingsworth 2013-01-27 23:02:41 EST
(In reply to comment #17)
> Shouldn't the cookie module be linked to
> /usr/lib/node_modules/request/node_modules/ ?

Fixed.

> What about not adding the nodejs-tobi-cookie dependency manually, but use
> the %nodejs_fixdep macro? That should add the require and do the link, right?

No, nodejs-tobi-cookie doesn't provide 'npm(tobi-cookie)' since no 'tobi-cookie' module exists in the npm registry.  Therefore, I have to do the link manually.  This is also fixed.

Spec: http://patches.fedorapeople.org/npm/nodejs-request.spec
SRPM: http://patches.fedorapeople.org/npm/nodejs-request-2.12.0-3.fc17.src.rpm

The URL works this time, I promise. ;-)
Comment 20 Miro Hrončok 2013-01-28 08:22:20 EST
(In reply to comment #19)
> Spec: http://patches.fedorapeople.org/npm/nodejs-request.spec
> SRPM:
> http://patches.fedorapeople.org/npm/nodejs-request-2.12.0-3.fc17.src.rpm
> 
> The URL works this time, I promise. ;-)
It's an old link :) Using http://patches.fedorapeople.org/npm/nodejs-request-2.12.0-4.fc17.src.rpm

> (In reply to comment #17)
> > Shouldn't the cookie module be linked to
> > /usr/lib/node_modules/request/node_modules/ ?
> 
> Fixed.
OK. (there is a typo in explaining comment registSry)

But: It is linked as tobi-cookie, but requested as cookie.

>  , Cookie = require('cookie')
>  , CookieJar = require('cookie/jar')

Will this work?

> > What about not adding the nodejs-tobi-cookie dependency manually, but use
> > the %nodejs_fixdep macro? That should add the require and do the link, right?
> 
> No, nodejs-tobi-cookie doesn't provide 'npm(tobi-cookie)' since no
> 'tobi-cookie' module exists in the npm registry.  Therefore, I have to do
> the link manually.  This is also fixed.
OK

(In reply to comment #18)
> I cannot see, where you apply the patch. Am i blind, or you are not doing it?
Fixed.
Comment 21 T.C. Hollingsworth 2013-01-28 21:05:07 EST
Brown paper bag bugs everywhere.  :-/

(In reply to comment #20)
> > (In reply to comment #17)
> > > Shouldn't the cookie module be linked to
> > > /usr/lib/node_modules/request/node_modules/ ?
> > 
> > Fixed.
> OK. (there is a typo in explaining comment registSry)

Fixed.
 
> But: It is linked as tobi-cookie, but requested as cookie.
> 
> >  , Cookie = require('cookie')
> >  , CookieJar = require('cookie/jar')
> 
> Will this work?

Nope, good catch.  Fixed.

Spec: http://patches.fedorapeople.org/npm/nodejs-request.spec
SRPM: http://patches.fedorapeople.org/npm/nodejs-request-2.12.0-5.fc17.src.rpm
Comment 22 Miro Hrončok 2013-01-28 21:22:08 EST
OK, now it seems OK. Package APPROVED.
Comment 23 T.C. Hollingsworth 2013-01-28 21:27:42 EST
New Package SCM Request
=======================
Package Name: nodejs-request
Short Description: Simplified HTTP request client
Owners: patches
Branches: f18 el6
InitialCC:
Comment 24 Jon Ciesla 2013-01-29 07:01:26 EST
Git done (by process-git-requests).
Comment 25 T.C. Hollingsworth 2013-01-29 14:45:44 EST
http://koji.fedoraproject.org/koji/taskinfo?taskID=4912716
Comment 26 Fedora Update System 2013-01-30 16:59:57 EST
nodejs-abbrev-1.0.4-2.fc18, nodejs-ansi-0.1.2-4.fc18, nodejs-async-0.1.22-3.fc18, nodejs-glob-3.1.14-2.fc18, nodejs-inherits-1.0.0-6.fc18, nodejs-graceful-fs-1.1.14-2.fc18, nodejs-minimatch-0.2.9-2.fc18, nodejs-mkdirp-0.3.4-2.fc18, nodejs-mute-stream-0.0.3-3.fc18, nodejs-read-1.0.4-4.fc18, nodejs-read-installed-0.0.4-2.fc18, nodejs-read-package-json-0.1.12-2.fc18, nodejs-retry-0.6.0-2.fc18, nodejs-rimraf-2.1.1-2.fc18, nodejs-slide-1.1.3-4.fc18, nodejs-uid-number-0.0.3-4.fc18, nodejs-sigmund-1.0.0-2.fc18, nodejs-osenv-0.0.3-2.fc18, nodejs-nopt-2.0.0-3.fc18, nodejs-lru-cache-2.2.1-2.fc18, nodejs-mime-1.2.7-2.fc18, nodejs-init-package-json-0.0.7-3.fc18, nodejs-fstream-0.1.21-3.fc18, nodejs-delayed-stream-0.0.5-2.fc18, nodejs-proto-list-1.2.2-2.fc18, nodejs-npm-registry-client-0.2.11-2.fc18, nodejs-form-data-0.0.6-2.fc18, nodejs-which-1.0.5-4.fc18, nodejs-chownr-0.0.1-6.fc18, nodejs-opts-1.2.2-2.fc18, nodejs-yamlish-0.0.5-1.fc18, nodejs-once-1.1.1-2.fc18, nodejs-lockfile-0.2.1-2.fc18, nodejs-ini-1.0.5-2.fc18, nodejs-couch-login-0.1.15-2.fc18, nodejs-archy-0.0.2-5.fc18, nodejs-block-stream-0.0.6-4.fc18, nodejs-config-chain-1.1.3-3.fc18, nodejs-fstream-npm-0.1.3-2.fc18, nodejs-npmconf-0.0.16-3.fc18, nodejs-npmlog-0.0.2-2.fc18, nodejs-charm-0.1.0-1.fc18, node-gyp-0.8.2-3.fc18, nodejs-tar-0.1.14-3.fc18, npm-1.2.1-2.fc18, nodejs-opener-1.3.0-4.fc18, nodejs-semver-1.1.2-1.fc18, nodejs-tobi-cookie-0.3.2-2.fc18, nodejs-fstream-ignore-0.0.5-4.fc18, nodejs-request-2.12.0-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2013-0775/npm-1.2.1-2.fc18,nodejs-abbrev-1.0.4-2.fc18,nodejs-ansi-0.1.2-4.fc18,nodejs-async-0.1.22-3.fc18,nodejs-glob-3.1.14-2.fc18,nodejs-inherits-1.0.0-6.fc18,nodejs-graceful-fs-1.1.14-2.fc18,nodejs-minimatch-0.2.9-2.fc18,nodejs-mkdirp-0.3.4-2.fc18,nodejs-mute-stream-0.0.3-3.fc18,nodejs-read-1.0.4-4.fc18,nodejs-read-installed-0.0.4-2.fc18,nodejs-read-package-json-0.1.12-2.fc18,nodejs-retry-0.6.0-2.fc18,nodejs-rimraf-2.1.1-2.fc18,nodejs-slide-1.1.3-4.fc18,nodejs-uid-number-0.0.3-4.fc18,nodejs-sigmund-1.0.0-2.fc18,nodejs-osenv-0.0.3-2.fc18,nodejs-nopt-2.0.0-3.fc18,nodejs-lru-cache-2.2.1-2.fc18,nodejs-mime-1.2.7-2.fc18,nodejs-init-package-json-0.0.7-3.fc18,nodejs-fstream-0.1.21-3.fc18,nodejs-delayed-stream-0.0.5-2.fc18,nodejs-proto-list-1.2.2-2.fc18,nodejs-npm-registry-client-0.2.11-2.fc18,nodejs-form-data-0.0.6-2.fc18,nodejs-which-1.0.5-4.fc18,nodejs-chownr-0.0.1-6.fc18,nodejs-opts-1.2.2-2.fc18,nodejs-yamlish-0.0.5-1.fc18,nodejs-once-1.1.1-2.fc18,nodejs-lockfile-0.2.1-2.fc18,nodejs-ini-1.0.5-2.fc18,nodejs-couch-login-0.1.15-2.fc18,nodejs-archy-0.0.2-5.fc18,nodejs-block-stream-0.0.6-4.fc18,nodejs-config-chain-1.1.3-3.fc18,nodejs-fstream-npm-0.1.3-2.fc18,nodejs-npmconf-0.0.16-3.fc18,nodejs-npmlog-0.0.2-2.fc18,nodejs-charm-0.1.0-1.fc18,node-gyp-0.8.2-3.fc18,nodejs-tar-0.1.14-3.fc18,nodejs-opener-1.3.0-4.fc18,nodejs-semver-1.1.2-1.fc18,nodejs-tobi-cookie-0.3.2-2.fc18,nodejs-fstream-ignore-0.0.5-4.fc18,nodejs-request-2.12.0-5.fc18
Comment 27 Fedora Update System 2013-02-01 12:41:18 EST
nodejs-abbrev-1.0.4-2.fc18, nodejs-ansi-0.1.2-4.fc18, nodejs-async-0.1.22-3.fc18, nodejs-glob-3.1.14-2.fc18, nodejs-inherits-1.0.0-6.fc18, nodejs-graceful-fs-1.1.14-2.fc18, nodejs-minimatch-0.2.9-2.fc18, nodejs-mkdirp-0.3.4-2.fc18, nodejs-mute-stream-0.0.3-3.fc18, nodejs-read-1.0.4-4.fc18, nodejs-read-installed-0.0.4-2.fc18, nodejs-read-package-json-0.1.12-2.fc18, nodejs-retry-0.6.0-2.fc18, nodejs-rimraf-2.1.1-2.fc18, nodejs-slide-1.1.3-4.fc18, nodejs-uid-number-0.0.3-4.fc18, nodejs-sigmund-1.0.0-2.fc18, nodejs-osenv-0.0.3-2.fc18, nodejs-nopt-2.0.0-3.fc18, nodejs-lru-cache-2.2.1-2.fc18, nodejs-mime-1.2.7-2.fc18, nodejs-init-package-json-0.0.7-3.fc18, nodejs-fstream-0.1.21-3.fc18, nodejs-delayed-stream-0.0.5-2.fc18, nodejs-proto-list-1.2.2-2.fc18, nodejs-npm-registry-client-0.2.11-2.fc18, nodejs-form-data-0.0.6-2.fc18, nodejs-which-1.0.5-4.fc18, nodejs-chownr-0.0.1-6.fc18, nodejs-opts-1.2.2-2.fc18, nodejs-yamlish-0.0.5-1.fc18, nodejs-once-1.1.1-2.fc18, nodejs-lockfile-0.2.1-2.fc18, nodejs-ini-1.0.5-2.fc18, nodejs-couch-login-0.1.15-2.fc18, nodejs-archy-0.0.2-5.fc18, nodejs-block-stream-0.0.6-4.fc18, nodejs-config-chain-1.1.3-3.fc18, nodejs-fstream-npm-0.1.3-2.fc18, nodejs-npmconf-0.0.16-3.fc18, nodejs-npmlog-0.0.2-2.fc18, nodejs-charm-0.1.0-1.fc18, node-gyp-0.8.2-3.fc18, nodejs-tar-0.1.14-3.fc18, npm-1.2.1-2.fc18, nodejs-opener-1.3.0-4.fc18, nodejs-semver-1.1.2-1.fc18, nodejs-tobi-cookie-0.3.2-2.fc18, nodejs-fstream-ignore-0.0.5-4.fc18, nodejs-request-2.12.0-5.fc18 has been pushed to the Fedora 18 testing repository.
Comment 28 Fedora Update System 2013-02-03 08:37:11 EST
nodejs-abbrev-1.0.4-2.fc18, nodejs-ansi-0.1.2-4.fc18, nodejs-async-0.1.22-3.fc18, nodejs-glob-3.1.14-2.fc18, nodejs-inherits-1.0.0-6.fc18, nodejs-graceful-fs-1.1.14-2.fc18, nodejs-minimatch-0.2.9-2.fc18, nodejs-mkdirp-0.3.4-2.fc18, nodejs-mute-stream-0.0.3-3.fc18, nodejs-read-1.0.4-4.fc18, nodejs-read-installed-0.0.4-2.fc18, nodejs-read-package-json-0.1.12-2.fc18, nodejs-retry-0.6.0-2.fc18, nodejs-rimraf-2.1.1-2.fc18, nodejs-slide-1.1.3-4.fc18, nodejs-uid-number-0.0.3-4.fc18, nodejs-sigmund-1.0.0-2.fc18, nodejs-osenv-0.0.3-2.fc18, nodejs-nopt-2.0.0-3.fc18, nodejs-lru-cache-2.2.1-2.fc18, nodejs-mime-1.2.7-2.fc18, nodejs-init-package-json-0.0.7-3.fc18, nodejs-fstream-0.1.21-3.fc18, nodejs-delayed-stream-0.0.5-2.fc18, nodejs-proto-list-1.2.2-2.fc18, nodejs-npm-registry-client-0.2.11-2.fc18, nodejs-form-data-0.0.6-2.fc18, nodejs-which-1.0.5-4.fc18, nodejs-chownr-0.0.1-6.fc18, nodejs-opts-1.2.2-2.fc18, nodejs-yamlish-0.0.5-1.fc18, nodejs-once-1.1.1-2.fc18, nodejs-lockfile-0.2.1-2.fc18, nodejs-ini-1.0.5-2.fc18, nodejs-couch-login-0.1.15-2.fc18, nodejs-archy-0.0.2-5.fc18, nodejs-block-stream-0.0.6-4.fc18, nodejs-config-chain-1.1.3-3.fc18, nodejs-fstream-npm-0.1.3-2.fc18, nodejs-npmconf-0.0.16-3.fc18, nodejs-npmlog-0.0.2-2.fc18, nodejs-charm-0.1.0-1.fc18, node-gyp-0.8.2-3.fc18, nodejs-tar-0.1.14-3.fc18, npm-1.2.1-2.fc18, nodejs-opener-1.3.0-4.fc18, nodejs-semver-1.1.2-1.fc18, nodejs-tobi-cookie-0.3.2-2.fc18, nodejs-fstream-ignore-0.0.5-4.fc18, nodejs-request-2.12.0-5.fc18, nodejs-promzard-0.2.0-3.fc18 has been pushed to the Fedora 18 testing repository.
Comment 29 Fedora Update System 2013-02-09 23:36:14 EST
nodejs-abbrev-1.0.4-2.fc18, nodejs-ansi-0.1.2-4.fc18, nodejs-inherits-1.0.0-6.fc18, nodejs-minimatch-0.2.9-2.fc18, nodejs-mkdirp-0.3.4-2.fc18, nodejs-mute-stream-0.0.3-3.fc18, nodejs-read-1.0.4-4.fc18, nodejs-retry-0.6.0-2.fc18, nodejs-slide-1.1.3-4.fc18, nodejs-uid-number-0.0.3-4.fc18, nodejs-sigmund-1.0.0-2.fc18, nodejs-osenv-0.0.3-2.fc18, nodejs-init-package-json-0.0.7-3.fc18, nodejs-delayed-stream-0.0.5-2.fc18, nodejs-proto-list-1.2.2-2.fc18, nodejs-which-1.0.5-4.fc18, nodejs-chownr-0.0.1-6.fc18, nodejs-opts-1.2.2-2.fc18, nodejs-yamlish-0.0.5-1.fc18, nodejs-once-1.1.1-2.fc18, nodejs-couch-login-0.1.15-2.fc18, nodejs-archy-0.0.2-5.fc18, nodejs-block-stream-0.0.6-4.fc18, nodejs-fstream-npm-0.1.3-2.fc18, nodejs-npmlog-0.0.2-2.fc18, nodejs-charm-0.1.0-1.fc18, nodejs-opener-1.3.0-4.fc18, nodejs-tobi-cookie-0.3.2-2.fc18, nodejs-request-2.12.0-5.fc18, nodejs-promzard-0.2.0-3.fc18, nodejs-async-0.2.4-1.fc18, nodejs-combined-stream-0.0.4-1.fc18, nodejs-config-chain-1.1.5-1.fc18, nodejs-form-data-0.0.6-3.fc18, nodejs-fstream-0.1.22-1.fc18, nodejs-fstream-ignore-0.0.6-1.fc18, nodejs-glob-3.1.20-1.fc18, nodejs-graceful-fs-1.2.0-1.fc18, nodejs-ini-1.1.0-1.fc18, nodejs-lockfile-0.3.0-1.fc18, nodejs-lru-cache-2.2.2-1.fc18, nodejs-mime-1.2.9-1.fc18, nodejs-nopt-2.1.1-1.fc18, nodejs-npmconf-0.0.23-1.fc18, nodejs-npm-registry-client-0.2.13-2.fc18, nodejs-read-installed-0.1.1-1.fc18, nodejs-read-package-json-0.1.13-1.fc18, nodejs-rimraf-2.1.4-1.fc18, nodejs-semver-1.1.3-1.fc18, nodejs-tar-0.1.16-1.fc18, node-gyp-0.8.4-1.fc18, npm-1.2.10-1.fc18 has been pushed to the Fedora 18 testing repository.
Comment 30 Fedora Update System 2013-02-12 00:26:45 EST
nodejs-abbrev-1.0.4-2.fc18, nodejs-ansi-0.1.2-4.fc18, nodejs-inherits-1.0.0-6.fc18, nodejs-minimatch-0.2.9-2.fc18, nodejs-mkdirp-0.3.4-2.fc18, nodejs-mute-stream-0.0.3-3.fc18, nodejs-read-1.0.4-4.fc18, nodejs-retry-0.6.0-2.fc18, nodejs-slide-1.1.3-4.fc18, nodejs-uid-number-0.0.3-4.fc18, nodejs-sigmund-1.0.0-2.fc18, nodejs-osenv-0.0.3-2.fc18, nodejs-init-package-json-0.0.7-3.fc18, nodejs-delayed-stream-0.0.5-2.fc18, nodejs-proto-list-1.2.2-2.fc18, nodejs-which-1.0.5-4.fc18, nodejs-chownr-0.0.1-6.fc18, nodejs-opts-1.2.2-2.fc18, nodejs-yamlish-0.0.5-1.fc18, nodejs-once-1.1.1-2.fc18, nodejs-couch-login-0.1.15-2.fc18, nodejs-archy-0.0.2-5.fc18, nodejs-block-stream-0.0.6-4.fc18, nodejs-fstream-npm-0.1.3-2.fc18, nodejs-npmlog-0.0.2-2.fc18, nodejs-opener-1.3.0-4.fc18, nodejs-tobi-cookie-0.3.2-2.fc18, nodejs-request-2.12.0-5.fc18, nodejs-promzard-0.2.0-3.fc18, nodejs-async-0.2.4-1.fc18, nodejs-combined-stream-0.0.4-1.fc18, nodejs-config-chain-1.1.5-1.fc18, nodejs-fstream-0.1.22-1.fc18, nodejs-fstream-ignore-0.0.6-1.fc18, nodejs-glob-3.1.20-1.fc18, nodejs-graceful-fs-1.2.0-1.fc18, nodejs-ini-1.1.0-1.fc18, nodejs-lockfile-0.3.0-1.fc18, nodejs-lru-cache-2.2.2-1.fc18, nodejs-mime-1.2.9-1.fc18, nodejs-nopt-2.1.1-1.fc18, nodejs-npmconf-0.0.23-1.fc18, nodejs-npm-registry-client-0.2.13-2.fc18, nodejs-read-installed-0.1.1-1.fc18, nodejs-read-package-json-0.1.13-1.fc18, nodejs-rimraf-2.1.4-1.fc18, nodejs-semver-1.1.3-1.fc18, nodejs-tar-0.1.16-1.fc18, node-gyp-0.8.4-1.fc18, npm-1.2.10-1.fc18, nodejs-form-data-0.0.6-4.fc18 has been pushed to the Fedora 18 testing repository.
Comment 31 Fedora Update System 2013-02-13 21:41:57 EST
nodejs-abbrev-1.0.4-2.fc18, nodejs-ansi-0.1.2-4.fc18, nodejs-inherits-1.0.0-6.fc18, nodejs-minimatch-0.2.9-2.fc18, nodejs-mkdirp-0.3.4-2.fc18, nodejs-mute-stream-0.0.3-3.fc18, nodejs-read-1.0.4-4.fc18, nodejs-retry-0.6.0-2.fc18, nodejs-slide-1.1.3-4.fc18, nodejs-uid-number-0.0.3-4.fc18, nodejs-sigmund-1.0.0-2.fc18, nodejs-osenv-0.0.3-2.fc18, nodejs-init-package-json-0.0.7-3.fc18, nodejs-delayed-stream-0.0.5-2.fc18, nodejs-proto-list-1.2.2-2.fc18, nodejs-which-1.0.5-4.fc18, nodejs-chownr-0.0.1-6.fc18, nodejs-opts-1.2.2-2.fc18, nodejs-once-1.1.1-2.fc18, nodejs-couch-login-0.1.15-2.fc18, nodejs-archy-0.0.2-5.fc18, nodejs-block-stream-0.0.6-4.fc18, nodejs-fstream-npm-0.1.3-2.fc18, nodejs-npmlog-0.0.2-2.fc18, nodejs-opener-1.3.0-4.fc18, nodejs-tobi-cookie-0.3.2-2.fc18, nodejs-request-2.12.0-5.fc18, nodejs-promzard-0.2.0-3.fc18, nodejs-combined-stream-0.0.4-1.fc18, nodejs-config-chain-1.1.5-1.fc18, nodejs-fstream-0.1.22-1.fc18, nodejs-fstream-ignore-0.0.6-1.fc18, nodejs-glob-3.1.20-1.fc18, nodejs-graceful-fs-1.2.0-1.fc18, nodejs-ini-1.1.0-1.fc18, nodejs-lockfile-0.3.0-1.fc18, nodejs-lru-cache-2.2.2-1.fc18, nodejs-mime-1.2.9-1.fc18, nodejs-nopt-2.1.1-1.fc18, nodejs-npmconf-0.0.23-1.fc18, nodejs-read-installed-0.1.1-1.fc18, nodejs-rimraf-2.1.4-1.fc18, nodejs-semver-1.1.3-1.fc18, nodejs-tar-0.1.16-1.fc18, node-gyp-0.8.4-1.fc18, nodejs-async-0.2.5-1.fc18, nodejs-form-data-0.0.7-1.fc18, nodejs-npm-registry-client-0.2.15-1.fc18, nodejs-read-package-json-0.2.0-1.fc18, npm-1.2.10-2.fc18 has been pushed to the Fedora 18 testing repository.
Comment 32 Fedora Update System 2013-04-05 19:18:11 EDT
node-gyp-0.9.1-2.fc18, nodejs-async-0.2.6-1.fc18, nodejs-chmodr-0.1.0-2.fc18, nodejs-fstream-npm-0.1.4-1.fc18, nodejs-glob-3.1.21-1.fc18, nodejs-minimatch-0.2.11-1.fc18, nodejs-mkdirp-0.3.5-1.fc18, nodejs-npm-registry-client-0.2.18-2.fc18, nodejs-read-package-json-0.2.2-1.fc18, nodejs-request-2.14.0-1.fc18, nodejs-semver-1.1.4-1.fc18, npm-1.2.14-2.fc18, nodejs-abbrev-1.0.4-2.fc18, nodejs-ansi-0.1.2-4.fc18, nodejs-inherits-1.0.0-6.fc18, nodejs-mute-stream-0.0.3-3.fc18, nodejs-read-1.0.4-4.fc18, nodejs-retry-0.6.0-2.fc18, nodejs-slide-1.1.3-4.fc18, nodejs-uid-number-0.0.3-4.fc18, nodejs-sigmund-1.0.0-2.fc18, nodejs-osenv-0.0.3-2.fc18, nodejs-init-package-json-0.0.7-3.fc18, nodejs-delayed-stream-0.0.5-2.fc18, nodejs-proto-list-1.2.2-2.fc18, nodejs-which-1.0.5-4.fc18, nodejs-chownr-0.0.1-6.fc18, nodejs-opts-1.2.2-2.fc18, nodejs-once-1.1.1-2.fc18, nodejs-couch-login-0.1.15-2.fc18, nodejs-archy-0.0.2-5.fc18, nodejs-block-stream-0.0.6-4.fc18, nodejs-npmlog-0.0.2-2.fc18, nodejs-opener-1.3.0-4.fc18, nodejs-tobi-cookie-0.3.2-2.fc18, nodejs-promzard-0.2.0-3.fc18, nodejs-combined-stream-0.0.4-1.fc18, nodejs-config-chain-1.1.5-1.fc18, nodejs-fstream-0.1.22-1.fc18, nodejs-fstream-ignore-0.0.6-1.fc18, nodejs-graceful-fs-1.2.0-1.fc18, nodejs-ini-1.1.0-1.fc18, nodejs-lockfile-0.3.0-1.fc18, nodejs-lru-cache-2.2.2-1.fc18, nodejs-mime-1.2.9-1.fc18, nodejs-nopt-2.1.1-1.fc18, nodejs-npmconf-0.0.23-1.fc18, nodejs-read-installed-0.1.1-1.fc18, nodejs-rimraf-2.1.4-1.fc18, nodejs-tar-0.1.16-1.fc18, nodejs-form-data-0.0.7-1.fc18 has been pushed to the Fedora 18 stable repository.