Bug 893218

Summary: [abrt] anaconda-18.37.11-1.fc18: Gtk.py:1624:<module>:RuntimeError: Gtk couldn't be initialized
Product: [Fedora] Fedora Reporter: Steve Tyler <stephent98>
Component: gobject-introspectionAssignee: Colin Walters <walters>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: a.vanloon, fedora, g.kaviyarasu, jantho, jonathan, jreznik, otaylor, satellitgo, sbueno, stanley.king, stephent98, vanmeeuwen+fedora, vpodzime, vsatheesh.kumar21, walters
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:e041dd956f932e40e4f1d6b9c5784bcfce4c3ff4
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-04-08 13:33:16 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: backtrace
none
File: core_backtrace
none
File: dso_list
none
File: environ
none
anaconda.log
none
program.log
none
storage.log none

Description Steve Tyler 2013-01-08 17:49:51 EST
Description of problem:
Started Live CD installer in VM with networking disabled.

Version-Release number of selected component:
anaconda-18.37.11-1.fc18

Additional info:
cmdline:        /usr/bin/python /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
executable:     /sbin/anaconda
kernel:         3.6.10-4.fc18.x86_64
uid:            0
Comment 1 Steve Tyler 2013-01-08 17:49:53 EST
Created attachment 675115 [details]
File: backtrace
Comment 2 Steve Tyler 2013-01-08 17:49:55 EST
Created attachment 675116 [details]
File: core_backtrace
Comment 3 Steve Tyler 2013-01-08 17:49:57 EST
Created attachment 675117 [details]
File: dso_list
Comment 4 Steve Tyler 2013-01-08 17:49:58 EST
Created attachment 675118 [details]
File: environ
Comment 5 Steve Tyler 2013-01-08 17:52:43 EST
Command-line:
$ qemu-kvm -m 2048 -hda f18-test-1.img -cdrom ~/xfr/fedora/F18/F18-Final/RC2/Fedora-18-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on -usbdevice mouse
Comment 6 Steve Tyler 2013-01-08 17:59:58 EST
Created attachment 675119 [details]
anaconda.log
Comment 7 Steve Tyler 2013-01-08 18:00:55 EST
Created attachment 675120 [details]
program.log
Comment 8 Steve Tyler 2013-01-08 18:01:46 EST
Created attachment 675121 [details]
storage.log
Comment 9 Steve Tyler 2013-01-08 18:02:44 EST
ifcfg.log and packaging.log are empty.
Comment 10 Vratislav Podzimek 2013-01-21 05:10:30 EST
*** Bug 896687 has been marked as a duplicate of this bug. ***
Comment 11 Steve Tyler 2013-01-21 08:09:26 EST
This seems to be reliable reproducer.

Start Live image:
$ qemu-kvm -m 2048 -cdrom ~/xfr/fedora/F18/F18-Final/Final/Fedora-18-x86_64-Live-Desktop.iso -vga qxl -usbdevice mouse

Click Live System User to login.
Click Try Fedora.
Click Close.
Click network icon in panel.
Click Wired to turn networking Off.
Click Activities in panel.
Click installer icon.

An ABRT notification appears.
Click Report.
There is no apparent response -- I believe this is because the exception is owned by root.

Click Activities.
Click Show Applications.
Click the ABRT icon.
Click Show all problems.

The Gtk.py ... RuntimeError exception is listed.

Testing is with an F17 host:
$ rpm -q qemu-kvm
qemu-kvm-1.0.1-2.fc17.x86_64
Comment 12 Alexander van Loon 2013-01-26 04:32:42 EST
I've also encountered this issue a few times. I haven't tried to reproduce it consistently yet, but I've seen it happen two or three times already. What is notable for me is that it only occured so far when I had a network connection active instead of not having one like Steve.
Comment 13 Steve Tyler 2013-01-26 08:02:13 EST
Thanks Alex. Your comments in Bug 904014 helped me discover another reproducer for this one:

Start the Live image in a VM:
$ qemu-kvm -m 2048 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Final/Final/Fedora-18-x86_64-Live-Desktop.iso -vga qxl -boot menu=on -usbdevice mouse

Proceed to the desktop.
Start a terminal.

[liveuser@localhost ~]$ su
[root@localhost liveuser]# hostnamectl set-hostname f18-test-2
[root@localhost liveuser]# exit
exit
[liveuser@localhost ~]$ liveinst
No protocol specified
xhost:  unable to open display ":0"
Starting installer, one moment...
anaconda 18.37.11 for Fedora 18 started.
No protocol specified

** (anaconda:1940): WARNING **: Could not open X display
No protocol specified
Traceback (most recent call last):
  File "/sbin/anaconda", line 923, in <module>
    setupDisplay(anaconda, opts)
  File "/sbin/anaconda", line 585, in setupDisplay
    anaconda.initInterface()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/__init__.py", line 213, in initInterface
    from pyanaconda.ui.gui import GraphicalUserInterface
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 22, in <module>
    import meh.ui.gui
  File "/usr/lib/python2.7/site-packages/meh/ui/gui.py", line 23, in <module>
    from gi.repository import Gtk
  File "/usr/lib64/python2.7/site-packages/gi/importer.py", line 76, in load_module
    dynamic_module._load()
  File "/usr/lib64/python2.7/site-packages/gi/module.py", line 244, in _load
    overrides_modules = __import__('gi.overrides', fromlist=[self._namespace])
  File "/usr/lib64/python2.7/site-packages/gi/overrides/Gtk.py", line 1624, in <module>
    raise RuntimeError("Gtk couldn't be initialized")
RuntimeError: Gtk couldn't be initialized
[liveuser@localhost ~]$
Comment 14 satellitgo 2013-02-01 19:52:25 EST
seen with dd USB of Mate-live Cd :
 http://bitchx.ca/Image-FedoraMateCompiz.iso
:fails with this error if no network connection.
:Works fine if reboot with wired connection present.
:Liveinst (Install to Hard disk) Works in VirtualBox install as there is a wired connection
Comment 15 Chris Smart 2013-02-22 06:12:28 EST
On a physical test machine here I was able to repeat this error several times in a row, where the installer on KDE live image would crash with the above GTK error.

I then turned off my machine, unplugged my network cable and it then worked several times in a row.

I then plugged my network cable back in without a power off, and it still continued to work.

Not particularly helpful but at least it's not confined to VMs, and in my case it was the opposite to above (fails with error with network plugged in).

Will try to gather more information.
Comment 16 Chris Smart 2013-02-22 16:55:20 EST
Can someone please see if this works for them:

xhost +
liveinst
Comment 17 Chris Smart 2013-02-22 17:04:16 EST
This might be a re-occurrence of an old F15 bug:
https://bugzilla.redhat.com/show_bug.cgi?id=679486
Comment 18 Jaroslav Reznik 2013-02-26 14:39:42 EST
(In reply to comment #16)
> Can someone please see if this works for them:
> 
> xhost +
> liveinst

Chris,
yes, it works.
Comment 19 satellitgo 2013-04-08 10:52:40 EDT
I thought one had to be # (su) for liveinst to work....It is that way in Soas spin- But this does not seem to apply in a live CD in Virtual Box with f19:
Testing with f19 TC5 live desktop x86_64 in Virtual Box
 2358 MB 16,00 GB HD
1-) network detached + Live System User/settings:Airplane mode on
 $su 
 #liveinst 
 localuser: root being added to access control list 
 Starting installer....
 "anaconda 19.16.1 for Fedora 19 ... started.
 Not asking for VNC beause we have don't have a network"
 Anaconda appears in 2nd window

2-)VirtualBox: [x]Enable Network Adapter: Bridged Adapter eth0
 $su 
 #liveinst 
 localuser: root being added to access control list 
 Starting installer....
 "anaconda 19.16.1 for Fedora 19 ... started.
 Anaconda appears in 2nd window

3-)VirtualBox: [x]Enable Network Adapter: Bridged Adapter eth0
 (try with-out root)
 $liveinst
 localuser: root being added to access control list 
 Starting installer....
 "anaconda 19.16.1 for Fedora 19 ... started.
 Anaconda appears in 2nd window
Comment 20 Jaroslav Reznik 2013-04-08 13:33:16 EDT

*** This bug has been marked as a duplicate of bug 679486 ***