Bug 896687 - [abrt] anaconda-18.37.11-1.fc18: Gtk.py:1624:<module>:RuntimeError: Gtk couldn't be initialized
Summary: [abrt] anaconda-18.37.11-1.fc18: Gtk.py:1624:<module>:RuntimeError: Gtk could...
Keywords:
Status: CLOSED DUPLICATE of bug 893218
Alias: None
Product: Fedora
Classification: Fedora
Component: gobject-introspection
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Colin Walters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e041dd956f932e40e4f1d6b9c57...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-17 18:54 UTC by satheesh kumar
Modified: 2013-02-02 00:51 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-21 10:10:30 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (8.27 KB, text/plain)
2013-01-17 18:54 UTC, satheesh kumar
no flags Details
File: core_backtrace (829 bytes, text/plain)
2013-01-17 18:54 UTC, satheesh kumar
no flags Details
File: dso_list (65 bytes, text/plain)
2013-01-17 18:54 UTC, satheesh kumar
no flags Details
File: environ (3.29 KB, text/plain)
2013-01-17 18:54 UTC, satheesh kumar
no flags Details

Description satheesh kumar 2013-01-17 18:54:21 UTC
Description of problem:
Booted from Fedora 18 xfce spin.
Choosen to install fedora to harddisk.
As the installed was not working, I tryed launching the binary from terminal and obtained this error message

Version-Release number of selected component:
anaconda-18.37.11-1.fc18

Additional info:
cmdline:        /usr/bin/python /usr/sbin/anaconda
executable:     /usr/sbin/anaconda
kernel:         3.6.10-4.fc18.x86_64
uid:            0

Comment 1 satheesh kumar 2013-01-17 18:54:25 UTC
Created attachment 680447 [details]
File: backtrace

Comment 2 satheesh kumar 2013-01-17 18:54:28 UTC
Created attachment 680448 [details]
File: core_backtrace

Comment 3 satheesh kumar 2013-01-17 18:54:31 UTC
Created attachment 680449 [details]
File: dso_list

Comment 4 satheesh kumar 2013-01-17 18:54:34 UTC
Created attachment 680450 [details]
File: environ

Comment 5 satellitgo 2013-01-18 15:53:36 UTC
 Radek Vykydal 2013-01-18 04:20:46 EST

To satellit: your traceback from comment #17 will be tracked in bug #896687.


from :https://bugzilla.redhat.com/show_bug.cgi?id=893892 comment 17

satellit@bendbroadband.com 2013-01-16 07:18:42 EST

Created attachment 679506 [details]
Fedora-18-x86_64-Live-SoaS.iso sugar-terminal root# RuntimeError: Gtk couldn't be initialized

Comment 6 Steve Tyler 2013-01-18 16:19:08 UTC
This bug looks very similar and is assigned to gobject-introspection:
Bug 893218 - [abrt] anaconda-18.37.11-1.fc18: Gtk.py:1624:<module>:RuntimeError: Gtk couldn't be initialized

Comment 7 Vratislav Podzimek 2013-01-21 10:03:49 UTC
(In reply to comment #0)
> Description of problem:
> Booted from Fedora 18 xfce spin.
> Choosen to install fedora to harddisk.
> As the installed was not working, I tryed launching the binary from terminal
> and obtained this error message
> 
> Version-Release number of selected component:
> anaconda-18.37.11-1.fc18
> 
> Additional info:
> cmdline:        /usr/bin/python /usr/sbin/anaconda
There is a 'liveinst' command that should be used to run the live installer.

Comment 8 Vratislav Podzimek 2013-01-21 10:10:30 UTC
(In reply to comment #6)
> This bug looks very similar and is assigned to gobject-introspection:
> Bug 893218 - [abrt] anaconda-18.37.11-1.fc18:
> Gtk.py:1624:<module>:RuntimeError: Gtk couldn't be initialized
Exactly, this is a duplicate. Steve, could you please help with the debugging in the bug 893218? It definitely doesn't happen every time, so steps to reproduce would be really appreciated.

*** This bug has been marked as a duplicate of bug 893218 ***

Comment 9 satellitgo 2013-02-02 00:51:38 UTC
seen with dd USB of Mate-live Cd :
 http://bitchx.ca/Image-FedoraMateCompiz.iso
:fails with this error if no network connection.
:Works fine if reboot with wired connection present.
:Liveinst (Install to Hard disk) Works in VirtualBox install as there is a wired connection


Note You need to log in before you can comment on or make changes to this bug.