Bug 894430

Summary: TG2 quickstart has broken dep on repoze.who==1.0.19
Product: [Fedora] Fedora Reporter: Luke Macken <lmacken>
Component: python-tg-devtoolsAssignee: Luke Macken <lmacken>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: a.badger, lmacken, pfrields
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-11 17:32:50 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Luke Macken 2013-01-11 12:47:45 EST
Description of problem:

The TG2 quickstarts on F18 have a dependency issue.

pkg_resources.VersionConflict: (repoze.who 1.0.18 (/usr/lib/python2.7/site-packages), Requirement.parse('repoze.who==1.0.19'))

Version-Release number of selected component (if applicable):

python-repoze-who-1.0.18-7.fc18.noarch
python-tg-devtools-2.1.1-4.fc18.noarch
TurboGears2-2.1.4-4.fc18.noarch
Comment 1 Luke Macken 2013-01-11 12:48:24 EST
This version is apparently not upstream, and only found in the TG2 repos.

I just tested the quickstart with the current version in F18, 1.0.18, and they pass just fine.
Comment 2 Fedora Update System 2013-01-11 16:56:07 EST
python-tg-devtools-2.1.1-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-tg-devtools-2.1.1-5.fc18
Comment 3 Luke Macken 2013-01-11 17:32:50 EST

*** This bug has been marked as a duplicate of bug 759142 ***