Bug 759142 - Requirement.parse('repoze.who==1.0.19')
Requirement.parse('repoze.who==1.0.19')
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python-tg-devtools (Show other bugs)
rawhide
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
: 768561 768562 894430 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-01 09:13 EST by Jan ONDREJ
Modified: 2016-09-19 22:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-22 20:49:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2011-12-01 09:13:22 EST
Description of problem:
Current version of Turbogears2 requires repoze.who 1.0.19, please update.

Version-Release number of selected component (if applicable):
python-repoze-who-1.0.18-5.fc15.noarch
TurboGears2-2.1.1-1.fc16.noarch

How reproducible:
always after new kickstarted project

Steps to Reproduce:
1. paster quickstart -s -m test1 -p test1 -a
2. cd test1
3. paster serve
  
Actual results:
Traceback (most recent call last):
  File "/usr/bin/paster", line 9, in <module>
    load_entry_point('PasteScript==1.7.3', 'console_scripts', 'paster')()
  File "/usr/lib/python2.7/site-packages/paste/script/command.py", line 73, in run
    commands = get_commands()
  File "/usr/lib/python2.7/site-packages/paste/script/command.py", line 115, in get_commands
    plugins = pluginlib.resolve_plugins(plugins)
  File "/usr/lib/python2.7/site-packages/paste/script/pluginlib.py", line 81, in resolve_plugins
    pkg_resources.require(plugin)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 686, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 588, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
pkg_resources.VersionConflict: (repoze.who 1.0.18 (/usr/lib/python2.7/site-packages), Requirement.parse('repoze.who==1.0.19'))
Comment 1 Luke Macken 2013-01-11 17:30:49 EST
*** Bug 768562 has been marked as a duplicate of this bug. ***
Comment 2 Luke Macken 2013-01-11 17:31:01 EST
*** Bug 768561 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2013-01-11 17:32:49 EST
python-tg-devtools-2.1.1-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-tg-devtools-2.1.1-5.fc18
Comment 4 Luke Macken 2013-01-11 17:32:50 EST
*** Bug 894430 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2013-01-12 10:16:25 EST
Package python-tg-devtools-2.1.1-5.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-tg-devtools-2.1.1-5.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0677/python-tg-devtools-2.1.1-5.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-01-22 20:49:54 EST
python-tg-devtools-2.1.1-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.