Bug 896214

Summary: [abrt]: WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7993 brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]()
Product: [Fedora] Fedora Reporter: Jason Brown <locustmage>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: dave.kolaja, gansalmon, itamar, jfbeltran, jmoura1st, jonathan, kernel-maint, madhu.chinakonda, m.koshelev, vivekprakash86
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:47f93c8a41b9b758eb4706916fedc1119a46998b
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-07 11:38:47 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jason Brown 2013-01-16 15:48:16 EST
Description of problem:
this occured when i removed the power cord from my laptop

Additional info:
WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7993 brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]()
Hardware name: 0679                            
Modules linked in: vfat fat fuse ebtable_nat nf_conntrack_netbios_ns nf_conntrack_broadcast bnep ipt_MASQUERADE bluetooth ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi ib_iser rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi arc4 brcmsmac cordic brcmutil mac80211 cfg80211 bcma uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev coretemp media snd_hda_codec_hdmi snd_hda_codec_conexant snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_page_alloc snd_timer snd soundcore microcode ideapad_laptop i2c_i801 sparse_keymap iTCO_wdt iTCO_vendor_support mei lpc_ich intel_ips mfd_core rfkill joydev kvm binfmt_misc uinput i915 i2c_algo_bit crc32c_intel drm_kms_helper drm ums_realtek usb_storage r8169 mii i2c_core wmi video sunrpc
Pid: 768, comm: NetworkManager Not tainted 3.7.2-201.fc18.x86_64 #1
Call Trace:
 [<ffffffff8105e67f>] warn_slowpath_common+0x7f/0xc0
 [<ffffffff8105e6da>] warn_slowpath_null+0x1a/0x20
 [<ffffffffa0447c99>] brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]
 [<ffffffffa043a6bb>] brcms_ops_flush+0x3b/0x60 [brcmsmac]
 [<ffffffffa03c5316>] __ieee80211_recalc_idle+0x236/0x300 [mac80211]
 [<ffffffffa03c57a3>] ieee80211_recalc_idle+0x33/0x60 [mac80211]
 [<ffffffffa03bc9d1>] __ieee80211_scan_completed+0xc1/0x300 [mac80211]
 [<ffffffff8107997e>] ? work_cpu+0xe/0x20
 [<ffffffffa03be03b>] ieee80211_scan_cancel+0xfb/0x170 [mac80211]
 [<ffffffffa03c5ded>] ieee80211_do_stop+0x5cd/0x6a0 [mac80211]
 [<ffffffff81635355>] ? _raw_spin_unlock_bh+0x15/0x20
 [<ffffffff81544571>] ? dev_deactivate_many+0x1f1/0x240
 [<ffffffffa03c5eda>] ieee80211_stop+0x1a/0x20 [mac80211]
 [<ffffffff8152185d>] __dev_close_many+0x7d/0xc0
 [<ffffffff815218d8>] __dev_close+0x38/0x50
 [<ffffffff81527de1>] __dev_change_flags+0xa1/0x180
 [<ffffffff81527f78>] dev_change_flags+0x28/0x70
 [<ffffffff8153571a>] do_setlink+0x37a/0xa10
 [<ffffffff81306211>] ? nla_parse+0x31/0xe0
 [<ffffffff81306211>] ? nla_parse+0x31/0xe0
 [<ffffffff815367ee>] rtnl_newlink+0x36e/0x590
 [<ffffffff8128b579>] ? selinux_capable+0x39/0x50
 [<ffffffff81536014>] rtnetlink_rcv_msg+0x114/0x300
 [<ffffffff81535f00>] ? __rtnl_unlock+0x20/0x20
 [<ffffffff8154f711>] netlink_rcv_skb+0xb1/0xc0
 [<ffffffff81533265>] rtnetlink_rcv+0x25/0x40
 [<ffffffff8154f031>] netlink_unicast+0x1a1/0x220
 [<ffffffff8154f3b1>] netlink_sendmsg+0x301/0x3c0
 [<ffffffff8150d5ec>] sock_sendmsg+0xbc/0xf0
 [<ffffffff8150e497>] ? sock_recvmsg+0xd7/0x110
 [<ffffffff8150e24c>] __sys_sendmsg+0x3ac/0x3c0
 [<ffffffff81510399>] sys_sendmsg+0x49/0x90
 [<ffffffff8163dad9>] system_call_fastpath+0x16/0x1b

Potential duplicate: bug 796023
Comment 1 Mikhail Koshelev 2013-01-25 14:12:49 EST
Acer One 722, booted on batery. The error is shown right away. Still network is accessible.
Run yum update - it loaded a few files, then started to fail reporting repos unavailable. Ping checked the gateway - no responce, though network manages still showed wireless connection as available.
  


Package: kernel
Architecture: i686
OS Release: Fedora release 18 (Spherical Cow)
Comment 2 Dave Jones 2013-02-07 11:38:47 EST

*** This bug has been marked as a duplicate of bug 862180 ***