Bug 862180 - WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7998 brcms_c_wait_for_tx_completion+0x99/0xb0
WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7998 brcms_c_wait_...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John Greene
Fedora Extras Quality Assurance
:
: 863745 881938 893798 894153 896214 896383 902085 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 03:59 EDT by Jóhann B. Guðmundsson
Modified: 2013-03-06 11:33 EST (History)
22 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-06 11:33:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2012-10-02 03:59:45 EDT
Description of problem:

Oct 02 07:25:32 localhost kernel: ------------[ cut here ]------------
Oct 02 07:25:32 localhost kernel: WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7998 brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac](
Oct 02 07:25:32 localhost kernel: Hardware name: HP Pavilion dm1 Notebook PC
Oct 02 07:25:32 localhost kernel: Modules linked in: fuse snd_hda_codec_hdmi snd_hda_codec_idt arc4 brcmsmac cordic brcmutil mac80211 uinput radeon kv
Oct 02 07:25:32 localhost kernel: Pid: 6, comm: kworker/u:0 Not tainted 3.6.0-1.fc18.x86_64 #1
Oct 02 07:25:32 localhost kernel: Call Trace:
Oct 02 07:25:32 localhost kernel:  [<ffffffff8105b83f>] warn_slowpath_common+0x7f/0xc0
Oct 02 07:25:32 localhost kernel:  [<ffffffff8105b89a>] warn_slowpath_null+0x1a/0x20
Oct 02 07:25:32 localhost kernel:  [<ffffffffa04baca9>] brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]
Oct 02 07:25:32 localhost kernel:  [<ffffffffa04ad6ab>] brcms_ops_flush+0x3b/0x60 [brcmsmac]
Oct 02 07:25:32 localhost kernel:  [<ffffffffa042d81d>] ieee80211_scan_work+0x34d/0x5f0 [mac80211]
Oct 02 07:25:32 localhost kernel:  [<ffffffff8101257b>] ? __switch_to+0x12b/0x420
Oct 02 07:25:32 localhost kernel:  [<ffffffff81077957>] process_one_work+0x147/0x4a0
Oct 02 07:25:32 localhost kernel:  [<ffffffffa042d4d0>] ? ieee80211_run_deferred_scan+0x90/0x90 [mac80211]
Oct 02 07:25:32 localhost kernel:  [<ffffffff8107985e>] worker_thread+0x15e/0x480
Oct 02 07:25:32 localhost kernel:  [<ffffffff81079700>] ? manage_workers+0x2f0/0x2f0
Oct 02 07:25:32 localhost kernel:  [<ffffffff8107ec23>] kthread+0x93/0xa0
Oct 02 07:25:32 localhost kernel:  [<ffffffff81629144>] kernel_thread_helper+0x4/0x10
Oct 02 07:25:32 localhost kernel:  [<ffffffff8107eb90>] ? kthread_freezable_should_stop+0x70/0x70
Oct 02 07:25:32 localhost kernel:  [<ffffffff81629140>] ? gs_change+0x13/0x13
Oct 02 07:25:32 localhost kernel: ---[ end trace db083f7b6c7f5ba3 ]---


Version-Release number of selected component (if applicable):

3.6.0-1.fc18.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Boot
2.
3.
  
Actual results:


Expected results:


Additional info:

I also noticed when installing and booting 3.6.0-1.fc18.x86_64 this morning that the screen flickered couple of time then just went black but was lid and the laptop seem to have hanged. Removing"quiet" from the kernel command line workaround that problem. I'm going to see if I cant gather some useful info on why that's happening and file it in a separate report
Comment 1 Stanislaw Gruszka 2012-10-05 08:34:50 EDT
F18 version of well known bug.
Comment 2 Josh Boyer 2012-11-12 16:05:49 EST
*** Bug 863745 has been marked as a duplicate of this bug. ***
Comment 3 Dave Jones 2013-02-07 11:38:29 EST
*** Bug 881938 has been marked as a duplicate of this bug. ***
Comment 4 Dave Jones 2013-02-07 11:38:33 EST
*** Bug 893798 has been marked as a duplicate of this bug. ***
Comment 5 Dave Jones 2013-02-07 11:38:39 EST
*** Bug 894153 has been marked as a duplicate of this bug. ***
Comment 6 Dave Jones 2013-02-07 11:38:48 EST
*** Bug 896214 has been marked as a duplicate of this bug. ***
Comment 7 Dave Jones 2013-02-07 11:38:55 EST
*** Bug 896383 has been marked as a duplicate of this bug. ***
Comment 8 Dave Jones 2013-02-07 11:39:06 EST
*** Bug 902085 has been marked as a duplicate of this bug. ***
Comment 9 Stanislaw Gruszka 2013-02-14 05:29:27 EST
This is Fedora top problem currently according to
https://retrace.fedoraproject.org/faf/problems/hot/*/*/kernel/

This issue (or actually a few issues which manifest itself by this warning) should be fixed in 3.8. Not sure when fedora 18 (and fedora 17) will update to 3.8 kernel, perhaps would be good to backport driver from 3.8 to 3.7 kernel?
Comment 10 Josh Boyer 2013-02-14 10:13:22 EST
(In reply to comment #9)
> This is Fedora top problem currently according to
> https://retrace.fedoraproject.org/faf/problems/hot/*/*/kernel/
> 
> This issue (or actually a few issues which manifest itself by this warning)
> should be fixed in 3.8. Not sure when fedora 18 (and fedora 17) will update
> to 3.8 kernel, perhaps would be good to backport driver from 3.8 to 3.7
> kernel?

F18/F17 will pick up 3.8 right around the 3.8.1 timeframe, so most likely within the next few weeks.  We had discussed doing a backport, but figured we would just wait.  If a backport patchset showed up, we'd probably take it though :)
Comment 11 Dave Jones 2013-02-14 21:07:37 EST
in the meantime, the warning has been removed in the latest update, so we'll not see further reports of this at least.
Comment 12 ghherlin 2013-02-15 03:06:34 EST
Appeared after first log in after boot... No action on my part.

Package: kernel
OS Release: Fedora release 18 (Spherical Cow)
Comment 13 arvind.bernaulli 2013-02-15 09:10:19 EST
after upgrade

Package: kernel
OS Release: Fedora release 18 (Spherical Cow)
Comment 14 Dave Jones 2013-03-06 11:33:41 EST
This should be fixed in the 3.8 updates. If you see new brcmsmac bugs, please file separate ones, as they won't be related to this due to the code being completely different.

Note You need to log in before you can comment on or make changes to this bug.