Bug 901439

Summary: libguestfs: error: aug_init: Augeas initialization failed
Product: [Fedora] Fedora Reporter: Etsuji Nakai <enakai>
Component: libguestfsAssignee: Richard W.M. Jones <rjones>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: justin.brown1.1, mbooth, pbrady, p, rjones, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-18 04:53:57 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
ad-hoc patch to disable using virtio-scsi
none
/etc directory contents of guest image none

Description Etsuji Nakai 2013-01-18 03:05:17 EST
Description of problem:

On 

/var/log/nova/compute.log
----
Failed to mount filesystem: Unexpected error while running command.
Command: sudo nova-rootwrap /etc/nova/rootwrap.conf guestmount --rw -a /var/lib/nova/instances/instance-00000001/disk -i /tmp/openstack-disk-mount-tmpT6ZpmE
Exit code: 1
Stdout: ''
Stderr: 'libguestfs: error: aug_init: Augeas initialization failed\n')
----

I'm using the image fetched from http://berrange.fedorapeople.org/images/2012-11-15/f17-x86_64-openstack-sda.qcow2
The following is a log of mounting the image directly with guestmount command.

http://pastebin.com/zRPG4gtF

SELinux is permissive and libguestfs version is as below.
----
# getenforce
Permissive

# rpm -qa | grep libguestfs
libguestfs-1.20.1-2.fc18.x86_64
libguestfs-tools-c-1.20.1-2.fc18.x86_64
----


Additional info:
Comment 1 Etsuji Nakai 2013-01-18 03:09:36 EST
Created attachment 682200 [details]
ad-hoc patch to disable using virtio-scsi
Comment 2 Etsuji Nakai 2013-01-18 03:11:42 EST
I suspect this is related to virtio-scsi. So I applied an ad-hoc patch on libguestfs to disable using virtio-scsi (See Comment 1).

guestmount worked well with the patch.
Comment 3 Pádraig Brady 2013-01-18 04:43:25 EST
We're really only calling out to libguestfs here. Changing components, thanks.
Comment 4 Richard W.M. Jones 2013-01-18 04:49:56 EST
Likely to be an instance of:

https://bugzilla.redhat.com/show_bug.cgi?id=894241
Comment 5 Richard W.M. Jones 2013-01-18 04:51:58 EST
... although why disabling virtio-scsi would make any difference
I have no idea.  Anyway, the original bug report does look a
lot like the augeas bug (bug 894241), so you could try asking
dlutter to take a closer look into it.
Comment 6 Richard W.M. Jones 2013-01-18 04:53:57 EST
In fact this is so similar it must be a duplicate.

Etsuji-san, could you capture the /etc directory from the guest.
The instructions for doing this are here:

https://bugzilla.redhat.com/show_bug.cgi?id=894241#c8

*** This bug has been marked as a duplicate of bug 894241 ***
Comment 7 Etsuji Nakai 2013-01-18 05:55:01 EST
Created attachment 682329 [details]
/etc directory contents of guest image

Hi. Do you mean the /etc contents of the guest image (which guestmount fails to mount)? If so, this is one extracted with virt-tar-out.

If you need any other information, please let me know. Thanks.
Comment 8 Richard W.M. Jones 2013-01-18 10:12:15 EST
(In reply to comment #7)
> Created attachment 682329 [details]
> /etc directory contents of guest image
> 
> Hi. Do you mean the /etc contents of the guest image (which guestmount fails
> to mount)? If so, this is one extracted with virt-tar-out.
> 
> If you need any other information, please let me know. Thanks.

Thanks -- actually I don't think we need that.

Please try the following package and up-vote it if it
works for you:

https://admin.fedoraproject.org/updates/libguestfs-1.20.1-3.fc18
Comment 9 Etsuji Nakai 2013-01-18 19:22:48 EST
Thanks, it worked well for me :)

https://admin.fedoraproject.org/updates/libguestfs-1.20.1-3.fc18

By the way, the reason why my ad-hoc patch (disabling virtio-scsi) worked may have nothing to do with virtio-scsi. As in https://bugzilla.redhat.com/show_bug.cgi?id=894241#c11 , it resolved the issue because I rebuilt it to apply the pactch, probably.
Comment 10 Richard W.M. Jones 2013-01-25 17:14:37 EST
*** Bug 904261 has been marked as a duplicate of this bug. ***