This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 904261 - Virt-Sysprep Failure
Virt-Sysprep Failure
Status: CLOSED DUPLICATE of bug 901439
Product: Fedora
Classification: Fedora
Component: libguestfs (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-25 16:43 EST by Justin Brown
Modified: 2013-01-25 17:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-25 17:14:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Virt-sysprep verbose output (44.49 KB, application/octet-stream)
2013-01-25 16:43 EST, Justin Brown
no flags Details

  None (edit)
Description Justin Brown 2013-01-25 16:43:48 EST
Created attachment 687684 [details]
Virt-sysprep verbose output

Description of problem:
Trying to sysprep a new KVM virtual machine.

Version-Release number of selected component (if applicable):
1.18.11 (libguestfs-tools)

How reproducible:
Virt-sysprep used to work for me, but no matter what I try now, it always fails.

Steps to Reproduce:
1. Create a master image template VM and power off VM.
2. copy from the template to new image by either
  A. virt-sparsify template.img new.img
  B. cp --sparse=always template.img new.img
3. Run sysprep `virt-sysprep --hostname new -a new.img`
  
Actual results:
Virt-sysprep operation failed: exception: Guestfs.Error("aug_init: Augeas initialization failed")

Expected results:
Virt-sysprep should succeed or provide a more useful error message. 


Additional info:
Verbose output is attached.
Comment 1 Justin Brown 2013-01-25 16:51:25 EST
Additional detail about the VM and template.

$ file template.img 
template.img: x86 boot sector; GRand Unified Bootloader, stage1 version 0x3, boot drive 0x80, 1st sector stage2 0x46800, GRUB version 0.94; partition 1: ID=0x83, active, starthead 32, startsector 2048, 10237952 sectors, code offset 0x48

$ file new.img 
splunk.img: x86 boot sector; GRand Unified Bootloader, stage1 version 0x3, boot drive 0x80, 1st sector stage2 0x46800, GRUB version 0.94; partition 1: ID=0x83, active, starthead 32, startsector 2048, 10237952 sectors, code offset 0x48

$ virt-inspector -a template.img 
libguestfs: error: aug_init: Augeas initialization failed
virt-inspector: no operating system could be detected inside this disk image.

This may be because the file is not a disk image, or is not a virtual machine
image, or because the OS type is not understood by libguestfs.

$  virt-inspector -a splunk.img 
libguestfs: error: aug_init: Augeas initialization failed
virt-inspector: no operating system could be detected inside this disk image.

This may be because the file is not a disk image, or is not a virtual machine
image, or because the OS type is not understood by libguestfs.

Both systems are EL6 guests with a single partition (/dev/vda1) and no swap.
$ virt-filesystems -a template.img 
/dev/sda1
Comment 2 Richard W.M. Jones 2013-01-25 17:14:37 EST
Please try the package from updates-testing.  See also:
https://www.redhat.com/archives/libguestfs/2013-January/msg00041.html

*** This bug has been marked as a duplicate of bug 901439 ***

Note You need to log in before you can comment on or make changes to this bug.