Bug 904231

Summary: Underspecific build requires
Product: Red Hat Enterprise Linux 5 Reporter: jcpunk
Component: java-1.7.0-openjdkAssignee: jiri vanek <jvanek>
Status: CLOSED CURRENTRELEASE QA Contact: BaseOS QE - Apps <qe-baseos-apps>
Severity: low Docs Contact:
Priority: unspecified    
Version: 5.9   
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-04-23 01:51:04 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description jcpunk 2013-01-25 14:41:49 EST
Description of problem:
The package cannot be built with zlib < 1.2.3-7.el5

Version-Release number of selected component (if applicable):java-1.7.0-openjdk-1.7.0.9-2.3.4.el5.1


How reproducible: always


Steps to Reproduce:
1. install zlib from RHEL5.6
2. rpmbuild --rebuild java-1.7.0-openjdk-1.7.0.9-2.3.4.el5.1.src.rpm
3. build requires 'pass' but an error fixed in 1.2.3-7.el5 will always happen
  
Actual results:
cannot build

Expected results:
build requires correctly requires the newer zlib

Additional info: