Bug 904979

Summary: stringtemplate package should require antlr-tool
Product: [Fedora] Fedora Reporter: Mohamed El Morabity <pikachu.2014>
Component: stringtemplateAssignee: Colin Walters <walters>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: cse.cem+redhatbugz, walters, xjakub
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-03-02 22:14:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 904572    

Description Mohamed El Morabity 2013-01-28 10:30:14 UTC
Description of problem:
stringtemplate depends on antlr.jar to work. According to the guidelines (see https://fedoraproject.org/wiki/Packaging:Java#BuildRequires_and_Requires), "All packages MUST be built from source and MUST enumerate their dependencies with Requires".

Version-Release number of selected component (if applicable):
stringtemplate-3.2.1-4.fc18.noarch

How reproducible:
See bug #904572 for example: antlrworks fails to run because stringtemplate cannot be detected, although being installed. The reason is that antlr.jar is missing whereas stringtemplate should requires the antlr-tool package. Notice that the CLASSPATH set to run antlrworks includes a reference to antlr.jar.

Comment 1 Conrad Meyer 2013-02-02 05:56:54 UTC
Fixed in rawhide git, kicked off a scratch build here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4923461

Assuming that succeeds, will merge to F-17 and F-18 and kick off builds / create updates. Thanks for filing the bug!

Comment 3 Fedora Update System 2013-02-02 06:51:11 UTC
stringtemplate-3.2.1-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/stringtemplate-3.2.1-5.fc18

Comment 4 Fedora Update System 2013-02-02 06:51:22 UTC
stringtemplate-3.2.1-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/stringtemplate-3.2.1-5.fc17

Comment 6 Fedora Update System 2013-02-11 04:56:54 UTC
stringtemplate-3.2.1-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2013-02-11 04:59:10 UTC
stringtemplate-3.2.1-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.