Bug 904572 - ANTLRworks cannot find the following libraries -Stringtemplate, and fails to start up
Summary: ANTLRworks cannot find the following libraries -Stringtemplate, and fails to ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: antlrworks
Version: 18
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Mohamed El Morabity
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 904979
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-26 14:58 UTC by Chrit van Ewijk
Modified: 2013-02-16 01:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-16 01:22:50 UTC


Attachments (Terms of Use)
a check of the installation of ANTLRWorks (639 bytes, text/plain)
2013-01-26 14:58 UTC, Chrit van Ewijk
no flags Details

Description Chrit van Ewijk 2013-01-26 14:58:28 UTC
Created attachment 688033 [details]
a check of the installation of ANTLRWorks

Description of problem:ANTLRWorks cannot find the following libraries:
-StringTemplate

The following message pops up on my screen each time i try to start up ANTLRWorks.

Missing libraries
ANTLRWorks cannot find the following libraries:
-StringTemplate
They are required in order to use all the features on ANTLRWorks.
Download them from www.antlr.org and put them in the same directory as ANTLRWorks

Version-Release number of selected component (if applicable):
See attachment.

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:Antlerworks does not start up.


Expected results:


Additional info:

Comment 1 Mohamed El Morabity 2013-01-28 10:35:55 UTC
Thanks for your bug report. An update will be soon available to fix this problem.
As a workaround, you can install the antlr-tool package. Without this package, stringtemplate can't work, and so looks unavailable to antlrworks.

Comment 2 Fedora Update System 2013-01-28 11:19:47 UTC
antlrworks-1.4.3-7.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/antlrworks-1.4.3-7.fc18

Comment 3 Fedora Update System 2013-01-30 00:53:16 UTC
Package antlrworks-1.4.3-7.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing antlrworks-1.4.3-7.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1629/antlrworks-1.4.3-7.fc18
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2013-02-16 01:22:51 UTC
antlrworks-1.4.3-7.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.