This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 908899

Summary: New definition of poll_through_vdsm function is not reflected in the rest of the code
Product: [Community] Spacewalk Reporter: Stephen Herr <sherr>
Component: ClientsAssignee: Stephen Herr <sherr>
Status: CLOSED CURRENTRELEASE QA Contact: Red Hat Satellite QA List <satellite-qa-list>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 1.9CC: jtesar
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: rhn-virtualization-5.4.44-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 907847 Environment:
Last Closed: 2013-03-06 13:35:30 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 907847    
Bug Blocks: 917805    

Description Stephen Herr 2013-02-07 14:59:15 EST
+++ This bug was initially created as a clone of Bug #907847 +++

Description of problem:
rhn-virtualization-host-5.4.34-4.el6sat.noarch package introduces new parameter for function poll_through_vdsm that was not available in rhn-virtualization-host-5.4.14-8.el6sat.noarch:

/usr/share/rhn/virtualization/poller.py line 130
def poll_through_vdsm(server)
...

But rest of the code does not reflect that

/usr/share/rhn/virtualization/support.py line 85

if vdsm_enabled:
    domains = poller.poll_through_vdsm()



Version-Release number of selected component (if applicable):
rhn-virtualization-host-5.4.34-4.el6sat.noarch

How reproducible:
RHEV 3.1. hypervisor on RHEL6 host and rhn-virtualization-host-5.4.34-4-4.el6sat.noarch package from RHN Tool

Steps to Reproduce:
1. run rhn-profile-sync
  
Actual results:
Traceback (most recent call last):
  File "/usr/sbin/rhn-profile-sync", line 56, in <module>
    cli.run()
  File "/usr/share/rhn/up2date_client/rhncli.py", line 84, in run
    sys.exit(self.main() or 0)
  File "/usr/sbin/rhn-profile-sync", line 51, in main
    support.refresh()
  File "/usr/share/rhn/virtualization/support.py", line 82, in refresh
    domains = poller.poll_through_vdsm()
<type 'exceptions.TypeError'>: poll_through_vdsm() takes exactly 1 argument (0 given)


Expected results:
Finish without an error

Additional info:
Comment 1 Stephen Herr 2013-02-07 15:05:11 EST
Spacewalk master commit: 5f8c84dcff4c4d942c9e52485e8821b166c1771a
Comment 2 Stephen Herr 2013-03-01 12:07:53 EST
Marking bug as ON_QA since tonight's build of Spacewalk nightly is a release candidate for Spacewalk 1.9.
Comment 3 Stephen Herr 2013-03-06 13:35:30 EST
Spacewalk 1.9 has been released.

https://fedorahosted.org/spacewalk/wiki/ReleaseNotes19