Bug 909444

Summary: [abrt] fedora-easy-karma-0-0.17.20110825git36efb338.fc18: cookies.py:281:_find_no_duplicates:CookieConflictError: There are multiple cookies with name, 'tg-visit'
Product: [Fedora] Fedora Reporter: Andre Robatino <robatino>
Component: python-requestsAssignee: Arun S A G <sagarun>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: a.badger, jstanley, lmacken, ricky, sagarun
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: abrt_hash:13be7352f70492b04aec01a5f58eefc0be111e40
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-09 11:19:02 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: backtrace
none
File: core_backtrace
none
File: dso_list
none
File: environ none

Description Andre Robatino 2013-02-08 14:47:41 EST
Version-Release number of selected component:
fedora-easy-karma-0-0.17.20110825git36efb338.fc18

Additional info:
cmdline:        /usr/bin/python /usr/bin/fedora-easy-karma --fas-username=robatino
executable:     /usr/bin/fedora-easy-karma
kernel:         3.7.6-201.fc18.x86_64
uid:            1000

Truncated backtrace:
cookies.py:281:_find_no_duplicates:CookieConflictError: There are multiple cookies with name, 'tg-visit'

Traceback (most recent call last):
  File "/usr/bin/fedora-easy-karma", line 510, in <module>
    FedoraEasyKarma()
  File "/usr/bin/fedora-easy-karma", line 310, in __init__
    testing_updates = bc.query(release=release, status="testing", limit=1000)["updates"]
  File "/usr/lib/python2.7/site-packages/fedora/client/bodhi.py", line 147, in query
    return self.send_request('list', req_params=params, auth=auth)
  File "/usr/lib/python2.7/site-packages/fedora/client/baseclient.py", line 344, in send_request
    auth_params=auth_params, retries=retries)
  File "/usr/lib/python2.7/site-packages/fedora/client/proxyclient.py", line 381, in send_request
    new_session = response.cookies.get(self.session_name, '')
  File "/usr/lib/python2.7/site-packages/requests/cookies.py", line 160, in get
    return self._find_no_duplicates(name, domain, path)
  File "/usr/lib/python2.7/site-packages/requests/cookies.py", line 281, in _find_no_duplicates
    raise CookieConflictError('There are multiple cookies with name, %r' % (name))
CookieConflictError: There are multiple cookies with name, 'tg-visit'

Local variables in innermost frame:
domain: None
name: 'tg-visit'
toReturn: '7fc6a94093bd12cfa41eb7f6fd49eb21372b35eb'
self: <<class 'requests.cookies.RequestsCookieJar'>[Cookie(version=0, name='tg-visit', value='7fc6a94093bd12cfa41eb7f6fd49eb21372b35eb', port=None, port_specified=False, domain='', domain_specified=False, domain_initial_dot=False, path='/', path_specified=True, secure=False, expires=None, discard=True, comment=None, comment_url=None, rest={'HttpOnly': None}, rfc2109=False), Cookie(version=0, name='tg-visit', value='79a283c71f2175a042a6eee70479faeae1a60894', port=None, port_specified=False, domain='admin.fedoraproject.org', domain_specified=False, domain_initial_dot=False, path='/', path_specified=True, secure=True, expires=None, discard=True, comment=None, comment_url=None, rest={'httponly': None}, rfc2109=False)]>
cookie: Cookie(version=0, name='tg-visit', value='79a283c71f2175a042a6eee70479faeae1a60894', port=None, port_specified=False, domain='admin.fedoraproject.org', domain_specified=False, domain_initial_dot=False, path='/', path_specified=True, secure=True, expires=None, discard=True, comment=None, comment_url=None, rest={'httponly': None}, rfc2109=False)
path: None
Comment 1 Andre Robatino 2013-02-08 14:47:44 EST
Created attachment 695222 [details]
File: backtrace
Comment 2 Andre Robatino 2013-02-08 14:47:47 EST
Created attachment 695223 [details]
File: core_backtrace
Comment 3 Andre Robatino 2013-02-08 14:47:49 EST
Created attachment 695224 [details]
File: dso_list
Comment 4 Andre Robatino 2013-02-08 14:47:51 EST
Created attachment 695225 [details]
File: environ
Comment 5 Andre Robatino 2013-02-08 14:49:01 EST
This is currently happening in my F16, F17, and F18 updates-testing guests when trying to run f-e-k. It started on all three at the same time (yesterday, I think) and continues today.
Comment 6 Till Maas 2013-02-09 05:42:15 EST
This needs to be fixed in python-fedora.
Comment 7 Andre Robatino 2013-02-09 08:57:44 EST
Confirm that downgrading python-fedora fixes the bug in F16, F17, and F18 (although I had to downgrade manually in F16 and F17 since the broken version is still present in those, it was only removed in F18).
Comment 9 Toshio Ernie Kuratomi 2013-02-09 11:19:02 EST
Excellent.  Looks like it's the bug fixed in 906924 then.

*** This bug has been marked as a duplicate of bug 906924 ***