Bug 906924 - [patch] Backport support correct cookie handling
Summary: [patch] Backport support correct cookie handling
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-requests   
(Show other bugs)
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Arun S A G
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 909296 909444 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-01 22:31 UTC by Ralph Bean
Modified: 2013-02-17 03:32 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-17 03:32:05 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Handle cookies correctly (1.33 KB, patch)
2013-02-01 22:31 UTC, Ralph Bean
no flags Details | Diff
Changes to the spec file (4.73 KB, patch)
2013-02-08 20:25 UTC, Toshio Ernie Kuratomi
no flags Details | Diff
Patch to enable the system cert bundle (523 bytes, patch)
2013-02-08 20:25 UTC, Toshio Ernie Kuratomi
no flags Details | Diff

Description Ralph Bean 2013-02-01 22:31:47 UTC
Created attachment 691772 [details]
Handle cookies correctly

We found a weird corner case in python-requests-0.14.1 in the way that it handles cookies.  It is discussed here:  https://github.com/fedora-infra/python-fedora/pull/6

Fixing it ended up requiring a patch that I have added to python-requests-0.14.1-3.el6.  This is a request to merge that patch back into rawhide and f18.

The patch is attached.  A simple "git merge" from el6 into the master and f18 branches should do it.

Comment 1 Toshio Ernie Kuratomi 2013-02-01 22:37:16 UTC
One note -- the patch is not quite a backport.  The python-requests-1.0.0 release doesn't have this problem but 1.0.0 was a huge restructuring of code.  So this was fix doesn't have an analogoue in the upstream 1.0.0 tree.

Comment 2 Toshio Ernie Kuratomi 2013-02-08 15:13:15 UTC
*** Bug 909296 has been marked as a duplicate of this bug. ***

Comment 3 Toshio Ernie Kuratomi 2013-02-08 15:15:21 UTC
Arun, mind if I apply the patch and rebuild?  The broken behavior was noticed by someone running fedora-easy-karma today.

Comment 4 Arun S A G 2013-02-08 16:44:48 UTC
Sure,  Not a problem. Go ahead!

Comment 5 Toshio Ernie Kuratomi 2013-02-08 20:21:31 UTC
I got carried away a little bit.  Made a few changes above and beyond what we talked about here.  I'll upload the patch and then build it if either one of you okay it.

Comment 6 Toshio Ernie Kuratomi 2013-02-08 20:25:16 UTC
Created attachment 695229 [details]
Changes to the spec file

This fixes the cookie handling, fixes the certificate bundle in https://bugzilla.redhat.com/show_bug.cgi?id=904614 , and removes the py-3 specific and py2-specific modules in the packages where they won't run (chardet is not in python-requests and chardet2, oauthlib is removed from python3-requests) so that we can use the generic fedora python byte compilation.

Comment 7 Toshio Ernie Kuratomi 2013-02-08 20:25:52 UTC
Created attachment 695230 [details]
Patch to enable the system cert bundle

Comment 8 Ralph Bean 2013-02-08 20:31:18 UTC
+1 to the patches.  Thanks for all your work on this Toshio!

Comment 9 Fedora Update System 2013-02-08 22:31:15 UTC
python-fedora-0.3.32.3-1.fc18, python-requests-0.14.1-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2013-1998/python-requests-0.14.1-4.fc18,python-fedora-0.3.32.3-1.fc18

Comment 10 Toshio Ernie Kuratomi 2013-02-09 16:19:02 UTC
*** Bug 909444 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2013-02-10 04:43:16 UTC
Package python-fedora-0.3.32.3-1.fc18, python-requests-0.14.1-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-fedora-0.3.32.3-1.fc18 python-requests-0.14.1-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1998/python-requests-0.14.1-4.fc18,python-fedora-0.3.32.3-1.fc18
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2013-02-17 03:32:07 UTC
python-fedora-0.3.32.3-1.fc18, python-requests-0.14.1-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.