Bug 914839

Summary: [abrt] wicd-curses-1.7.2.4-2.fc18: curses_misc.py:351:__init__:AttributeError: can't set attribute
Product: [Fedora] Fedora Reporter: David <davidmenhur>
Component: wicdAssignee: David Cantrell <dcantrell>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: dcantrell
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:d1eaf6f86d15a5570069b3e6328e9e040b7251d3
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-03-14 19:23:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
File: backtrace
none
File: core_backtrace
none
File: environ none

Description David 2013-02-22 22:56:10 UTC
Version-Release number of selected component:
wicd-curses-1.7.2.4-2.fc18

Additional info:
cmdline:        /usr/bin/python -O /usr/share/wicd/curses/wicd-curses.py
dso_list:       python-urwid-1.1.1-1.fc18.x86_64
executable:     /usr/share/wicd/curses/wicd-curses.py
kernel:         3.7.9-201.fc18.x86_64
uid:            0

Truncated backtrace:
curses_misc.py:351:__init__:AttributeError: can't set attribute

Traceback (most recent call last):
  File "/usr/share/wicd/curses/wicd-curses.py", line 1067, in <module>
    main()
  File "/usr/share/wicd/curses/wicd-curses.py", line 995, in main
    ui.run_wrapper(run)
  File "/usr/lib64/python2.7/site-packages/urwid/raw_display.py", line 241, in run_wrapper
    return fn()
  File "/usr/share/wicd/curses/wicd-curses.py", line 88, in wrapper
    return func(*args, **kargs)
  File "/usr/share/wicd/curses/wicd-curses.py", line 1003, in run
    app = appGUI()
  File "/usr/share/wicd/curses/wicd-curses.py", line 548, in __init__
    self.wiredCB = urwid.Filler(WiredComboBox(wiredL))
  File "/usr/share/wicd/curses/wicd-curses.py", line 378, in __init__
    self.__super.__init__(use_enter=False)
  File "/usr/share/wicd/curses/curses_misc.py", line 351, in __init__
    self.focus = focus
AttributeError: can't set attribute

Local variables in innermost frame:
w: <Columns selectable box/flow widget>
user_args: None
list: []
focus: 0
label: ''
callback: None
attrs: ('body', 'editnfc')
str: ''
trash: []
focus_attr: 'focus'
self: <WiredComboBox selectable box/flow widget>
use_enter: False

Potential duplicate: bug 879155

Comment 1 David 2013-02-22 22:56:14 UTC
Created attachment 701396 [details]
File: backtrace

Comment 2 David 2013-02-22 22:56:17 UTC
Created attachment 701397 [details]
File: core_backtrace

Comment 3 David 2013-02-22 22:56:19 UTC
Created attachment 701398 [details]
File: environ

Comment 4 David Cantrell 2013-03-14 19:23:26 UTC

*** This bug has been marked as a duplicate of bug 894646 ***