Bug 879155 - [abrt] wicd-curses-1.7.2.1-4.fc17: curses_misc.py:351:__init__:AttributeError: can't set attribute
Summary: [abrt] wicd-curses-1.7.2.1-4.fc17: curses_misc.py:351:__init__:AttributeError...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wicd
Version: 17
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d1eaf6f86d15a5570069b3e6328...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-22 08:38 UTC by zeugop
Modified: 2013-04-01 22:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-01 22:30:56 UTC
Type: ---


Attachments (Terms of Use)
File: executable (37 bytes, text/plain)
2012-11-22 08:38 UTC, zeugop
no flags Details
File: environ (4.27 KB, text/plain)
2012-11-22 08:38 UTC, zeugop
no flags Details
File: dso_list (32 bytes, text/plain)
2012-11-22 08:38 UTC, zeugop
no flags Details
File: smolt_data (3.06 KB, text/plain)
2012-11-22 08:38 UTC, zeugop
no flags Details
File: core_backtrace (777 bytes, text/plain)
2012-11-22 08:38 UTC, zeugop
no flags Details

Description zeugop 2012-11-22 08:38:17 UTC
Version-Release number of selected component:
wicd-curses-1.7.2.1-4.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
cmdline:        /usr/bin/python -O /usr/share/wicd/curses/wicd-curses.py
kernel:         3.6.6-1.fc17.x86_64

backtrace:
:curses_misc.py:351:__init__:AttributeError: can't set attribute
:
:Traceback (most recent call last):
:  File "/usr/share/wicd/curses/wicd-curses.py", line 1072, in <module>
:    main()
:  File "/usr/share/wicd/curses/wicd-curses.py", line 1000, in main
:    ui.run_wrapper(run)
:  File "/usr/lib64/python2.7/site-packages/urwid/raw_display.py", line 241, in run_wrapper
:    return fn()
:  File "/usr/share/wicd/curses/wicd-curses.py", line 93, in wrapper
:    return func(*args, **kargs)
:  File "/usr/share/wicd/curses/wicd-curses.py", line 1008, in run
:    app = appGUI()
:  File "/usr/share/wicd/curses/wicd-curses.py", line 553, in __init__
:    self.wiredCB = urwid.Filler(WiredComboBox(wiredL))
:  File "/usr/share/wicd/curses/wicd-curses.py", line 383, in __init__
:    self.__super.__init__(use_enter=False)
:  File "/usr/share/wicd/curses/curses_misc.py", line 351, in __init__
:    self.focus = focus
:AttributeError: can't set attribute
:
:Local variables in innermost frame:
:w: <Columns selectable box/flow widget>
:user_args: None
:list: []
:focus: 0
:label: ''
:callback: None
:attrs: ('body', 'editnfc')
:str: ''
:trash: []
:focus_attr: 'focus'
:self: <WiredComboBox selectable box/flow widget>
:use_enter: False

Comment 1 zeugop 2012-11-22 08:38:19 UTC
Created attachment 649573 [details]
File: executable

Comment 2 zeugop 2012-11-22 08:38:21 UTC
Created attachment 649574 [details]
File: environ

Comment 3 zeugop 2012-11-22 08:38:23 UTC
Created attachment 649575 [details]
File: dso_list

Comment 4 zeugop 2012-11-22 08:38:24 UTC
Created attachment 649576 [details]
File: smolt_data

Comment 5 zeugop 2012-11-22 08:38:26 UTC
Created attachment 649577 [details]
File: core_backtrace

Comment 6 mcandido12 2013-01-31 22:43:57 UTC
Same here on Fedora 18. According to http://forums.gentoo.org/viewtopic-p-7176644.html the problem is python-urwid.

Comment 7 Fedora Update System 2013-03-14 19:05:17 UTC
wicd-1.7.2.1-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/wicd-1.7.2.1-5.fc17

Comment 8 Fedora Update System 2013-03-16 01:36:05 UTC
Package wicd-1.7.2.1-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wicd-1.7.2.1-5.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3930/wicd-1.7.2.1-5.fc17
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2013-04-01 22:30:57 UTC
wicd-1.7.2.1-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.