Bug 91596

Summary: whiptail: --infobox doesn't work in an xterm
Product: [Retired] Red Hat Linux Reporter: Alastair McKinstry <mckinstry>
Component: newtAssignee: Eido Inoue <havill>
Status: CLOSED WORKSFORME QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=55182
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-08-15 21:59:16 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Alastair McKinstry 2003-05-25 10:41:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030430 Galeon/1.3.4
Debian/1.3.4.20030509-1

Description of problem:
--infobox is almost useless in an xterm, because whiptail writes to the
other screen xterm makes available, and switches back on exit. Thus, the
infobox that was just displayed disappears.

I don't know if this is doable with slang, but in theory, --infobox
shouldn't do that -- instead, it should write directly to stdout, without
switching screens. Then when it exits, the infobox display would remain on
screen, as it is meant to.

Version-Release number of selected component (if applicable):
newt-0.51.4

How reproducible:
Always

Steps to Reproduce:
1. whiptail --infobox something
2.
3.
    

Actual Results:  doesn't show things on xterm

Additional info:

Comment 1 Eido Inoue 2003-08-15 21:59:16 UTC
Was not able to reproduce using either xterm (in XFree86-4.3.0-2),
gnome-terminal  2.2.1-3 (with vte 0.11.9-3), and using newt 0.51.4

Note that i used the dialog interface to whiptail to produce the infobox, with
the required height and width.