Bug 91596 - whiptail: --infobox doesn't work in an xterm
Summary: whiptail: --infobox doesn't work in an xterm
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: newt   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Jay Turner
URL: http://bugs.debian.org/cgi-bin/bugrep...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-25 10:41 UTC by Alastair McKinstry
Modified: 2015-01-08 00:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-15 21:59:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alastair McKinstry 2003-05-25 10:41:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030430 Galeon/1.3.4
Debian/1.3.4.20030509-1

Description of problem:
--infobox is almost useless in an xterm, because whiptail writes to the
other screen xterm makes available, and switches back on exit. Thus, the
infobox that was just displayed disappears.

I don't know if this is doable with slang, but in theory, --infobox
shouldn't do that -- instead, it should write directly to stdout, without
switching screens. Then when it exits, the infobox display would remain on
screen, as it is meant to.

Version-Release number of selected component (if applicable):
newt-0.51.4

How reproducible:
Always

Steps to Reproduce:
1. whiptail --infobox something
2.
3.
    

Actual Results:  doesn't show things on xterm

Additional info:

Comment 1 Eido Inoue 2003-08-15 21:59:16 UTC
Was not able to reproduce using either xterm (in XFree86-4.3.0-2),
gnome-terminal  2.2.1-3 (with vte 0.11.9-3), and using newt 0.51.4

Note that i used the dialog interface to whiptail to produce the infobox, with
the required height and width.


Note You need to log in before you can comment on or make changes to this bug.