Bug 917229 (CVE-2013-1801)

Summary: CVE-2013-1801 rubygem-httparty: YAML parameter parsing vulnerability
Product: [Other] Security Response Reporter: Kurt Seifried <kseifried>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Severity: high Docs Contact:
Priority: high    
Version: unspecifiedCC: bkabrda, bressers, ccoleman, dmcphers, jialiu, lmeyer, mmcgrath
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: impact=important,public=20130114,reported=20130301,source=oss-security,cvss2=7.5/AV:N/AC:L/Au:N/C:P/I:P/A:P,openshift-1/rubygem-httparty=affected,epel-all/rubygem-httparty=affected,fedora-all/rubygem-httparty=affected,cwe=CWE-502
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-07-04 00:48:35 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 917230, 917231, 917232    
Bug Blocks: 917242    

Description Kurt Seifried 2013-03-02 03:47:05 EST
Tasha Drew reports:

Researchers investigating the Rails parameter parsing vulnerability discovered 
that the same or similar vulnerable code had made its way into multiple other 
libraries. If your application uses these libraries to process untrusted data, 
it may still be vulnerable even if you have upgraded Rails. Check your Gemfile 
and Gemfile.lock for vulnerable versions of the following libraries, and if you
are using one, update it immediately.

You can update each of these by using "bundle update <gem name>". 

Vulnerable: <= 0.9.0

Fixed: 0.10.0

External references:


Comment 2 Kurt Seifried 2013-03-02 03:49:59 EST
Created rubygem-httparty tracking bugs for this issue

Affects: epel-all [bug 917231]
Comment 3 Kurt Seifried 2013-03-02 03:51:19 EST
Created rubygem-httparty tracking bugs for this issue

Affects: fedora-all [bug 917232]