Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 917229 - (CVE-2013-1801) CVE-2013-1801 rubygem-httparty: YAML parameter parsing vulnerability
CVE-2013-1801 rubygem-httparty: YAML parameter parsing vulnerability
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
All Linux
high Severity high
: ---
: ---
Assigned To: Red Hat Product Security
: Security
Depends On: 917230 917231 917232
Blocks: 917242
  Show dependency treegraph
Reported: 2013-03-02 03:47 EST by Kurt Seifried
Modified: 2015-07-31 02:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2014-07-04 00:48:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kurt Seifried 2013-03-02 03:47:05 EST
Tasha Drew reports:

Researchers investigating the Rails parameter parsing vulnerability discovered 
that the same or similar vulnerable code had made its way into multiple other 
libraries. If your application uses these libraries to process untrusted data, 
it may still be vulnerable even if you have upgraded Rails. Check your Gemfile 
and Gemfile.lock for vulnerable versions of the following libraries, and if you
are using one, update it immediately.

You can update each of these by using "bundle update <gem name>". 

Vulnerable: <= 0.9.0

Fixed: 0.10.0

External references:


Comment 2 Kurt Seifried 2013-03-02 03:49:59 EST
Created rubygem-httparty tracking bugs for this issue

Affects: epel-all [bug 917231]
Comment 3 Kurt Seifried 2013-03-02 03:51:19 EST
Created rubygem-httparty tracking bugs for this issue

Affects: fedora-all [bug 917232]

Note You need to log in before you can comment on or make changes to this bug.