Bug 926019

Summary: fails to start
Product: [Fedora] Fedora Reporter: udo <udovdh>
Component: privoxyAssignee: Gwyn Ciesla <gwync>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: dean, gwync
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-04-07 00:24:31 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description udo 2013-03-23 09:53:57 UTC
Description of problem: gives errorlevel 1, older version works


Version-Release number of selected component (if applicable):
privoxy-3.0.16-6.fc17.i686 works
privoxy-3.0.21-1.fc17 fails.

How reproducible:
yum update privoxy


Actual results:
Fails to start

Expected results:
Starts OK

Additional info:

Comment 1 udo 2013-03-23 09:59:01 UTC
*** Bug 926021 has been marked as a duplicate of this bug. ***

Comment 2 Dean Brettle 2013-03-26 19:49:51 UTC
I experienced the same problem. Looks like the latest version requires the existence of user.filter. Creating an empty one fixed the problem for me:

sudo touch /etc/privoxy/user.filter

Comment 3 udo 2013-03-27 14:49:56 UTC
Great tip, the newer version now does start.
Thanks!

Can the rpm be fixed to do this?
Can help other users...

Comment 4 Gwyn Ciesla 2013-03-27 15:20:00 UTC
Ugh.  Ok, I thought I fixed this, and I did.  But, (there's always a but) /etc/privoxy is marked config(noreplace), which is as it should be, but I think it's preventing user.filter from being created on upgrades.  I'll see about some scripting to create it on upgrade if it doesn't exist.

Comment 5 Fedora Update System 2013-03-27 16:03:38 UTC
privoxy-3.0.21-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/privoxy-3.0.21-2.fc17

Comment 6 Fedora Update System 2013-03-27 16:05:33 UTC
privoxy-3.0.21-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/privoxy-3.0.21-2.el6

Comment 7 Fedora Update System 2013-03-27 16:05:50 UTC
privoxy-3.0.21-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/privoxy-3.0.21-2.fc18

Comment 8 Fedora Update System 2013-03-29 01:24:31 UTC
Package privoxy-3.0.21-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing privoxy-3.0.21-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-4519/privoxy-3.0.21-2.fc18
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2013-04-07 00:24:33 UTC
privoxy-3.0.21-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2013-04-07 00:35:11 UTC
privoxy-3.0.21-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2013-04-15 17:54:26 UTC
privoxy-3.0.21-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.