Bug 926941

Summary: xfce4 weather applet becomes a cpu hog if forecast > 6 days
Product: [Fedora] Fedora Reporter: A <a1b7c2d9>
Component: xfce4-weather-pluginAssignee: Christoph Wickert <cwickert>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: 17CC: cwickert, raphoszap, rvcsaba, sky.rim08
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: xfce4-weather-plugin-0.8.3-1.fc19 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-05-18 22:35:49 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
rpm -qa \*devel\* | sort none

Description A 2013-03-24 06:52:27 EDT
Description of problem:
The XFCE4 weather applet starts using 100% CPU if forecast for at least 7 days is asked.

Version-Release number of selected component (if applicable):
Fedora 17
xfce4-weather-plugin-0.8.2-1.fc17.i686

How reproducible:
Every time; there was no problem till a few weeks ago.

Steps to Reproduce:
1. Add an XFCE4 weather applet to the XFCE4 panel.
2. Open the weather applet's properties.
3. Set the number of forecast days to 7 days or higher.
4. Close the properties window.
5. Click on the weather applet icon in the XFCE4 panel.
  
Actual results:
No forecast is displayed, the CPU usage of the XFCE4 weather applet goes up to 100%.

Expected results:
The forecast would be shown in a pop-up window.

Additional info:
N/A

Thanks in advance for having a look at this bug.
Comment 1 rvcsaba 2013-03-24 18:29:17 EDT
I use Fedora 18, and xfce4-weather-plugin-0.8.2-1.fc18.x86_64 same problem.

I compiled xfce4-weather-plugin-0.8.3 from source, and solved this problem.

Christoph, please build a new xfce4-weather-plugin-0.8.3 package! Thanks.
Comment 2 Christoph Wickert 2013-03-25 11:33:34 EDT
The problem with 0.8.3 is that it requires a user account and I cannot register one on behalf of the Fedora project. It's kind of a legal question.
Comment 3 Raphos 2013-03-25 17:23:58 EDT
Hi,

To rvcsaba@freemail.hu: could you please explain how you compiled xfce4-weather-plugin-0.8.3 ?

I tried the manipulation and get a GTK error during the compilation.

The description of my problem is here at http://forum.xfce.org/viewtopic.php?id=7915.

Thanks for your help !
Comment 4 rvcsaba 2013-03-25 19:55:19 EDT
(In reply to comment #3)

I used this source: http://git.xfce.org/panel-plugins/xfce4-weather-plugin/snapshot/xfce4-weather-plugin-0.8.3.tar.bz2

./autogen.sh --prefix=/usr/local

If I get error message, I installed missing dependencies and repeated ./autogen.sh --prefix=/usr/local command. If success this, then I used

make

su -c 'make install'

commands. I symlinked:

/usr/lib64/xfce4/panel/plugins/libweather.la -> /usr/local/lib/xfce4/panel/plugins/libweather.la

/usr/lib64/xfce4/panel/plugins/libweather.so -> /usr/local/lib/xfce4/panel/plugins/libweather.so

/usr/share/xfce4/weather -> /usr/local/share/xfce4/weather

/usr/share/xfce4/panel/plugins/weather.desktop -> /usr/local/share/xfce4/panel/plugins/weather.desktop
Comment 5 rvcsaba 2013-03-25 19:57:30 EDT
Created attachment 716279 [details]
rpm -qa \*devel\* | sort
Comment 6 rvcsaba 2013-03-25 20:00:48 EDT
(In reply to comment #3)

I remove original package, before installed from source:

yum erase xfce4-weather-plugin
Comment 7 rvcsaba 2013-03-25 20:09:48 EDT
(In reply to comment #3)

yum install gtk2-devel

;)
Comment 8 sky.rim08 2013-03-27 13:10:48 EDT
(In reply to comment #2)
> The problem with 0.8.3 is that it requires a user account and I cannot
> register one on behalf of the Fedora project. It's kind of a legal
> question.

That is plainly wrong. While the README file kindly asks distributors to register a geonames username so that credits won't run out (if many distributions with a lot of users happen to use the default name), it is nowhere written that registering a username is required. In fact, if you don't provide your own then the default will be used, and if credits run out, then the only thing that won't work will be autodetecting altitude and timezone, and both are not essential to the plugin's functionality and further can be provided manually. This autodetection is usually only performed once, at plugin setup, or whenever you choose another location. Besides, it is very unlikely credits will run out so soon except if someone is misusing the service.

This was discussed some time ago on the xfce mailing list, I just can't dig up the link right now.

Wouldn't it seem a bit strange, if not even malicious or sadistic, for the developer to first switch the datasource to a free provider because of troublesome license issues, and then later introduce a similar problem?
Comment 9 Raphos 2013-03-28 18:21:48 EDT
Hi,

Thank you rvcsaba for your help. I didn't strictly follow the solution given in comment 4 but here is how I did: http://forum.xfce.org/viewtopic.php?pid=29218#p29218

I really hope that one day the plugin update will be available in the Fedora repository. I don't want do this trick for each new version...

If it's impossible to have this update, you can just erase the old weather package (actually at 0.8.2-1) in the repository because the location search is broken !
Comment 10 Christoph Wickert 2013-04-29 05:25:58 EDT
*** Bug 957688 has been marked as a duplicate of this bug. ***
Comment 11 Christoph Wickert 2013-04-29 05:55:24 EDT
(In reply to comment #8)

> That is plainly wrong. While the README file kindly asks distributors to
> register a geonames username so that credits won't run out (if many
> distributions with a lot of users happen to use the default name), it is
> nowhere written that registering a username is required. 

I think the truth is somewhere in the middle. While "required" may not be the correct wording, "kindly asked" isn't correct either as it's a technical requirement to prevent running out of credits.

> In fact, if you
> don't provide your own then the default will be used, and if credits run
> out, then the only thing that won't work will be autodetecting altitude and
> timezone, and both are not essential to the plugin's functionality and
> further can be provided manually.

Ok sorry, I was under the impression this was required any kind of lookation lookup. My bad.
Comment 12 Fedora Update System 2013-04-29 06:00:48 EDT
xfce4-weather-plugin-0.8.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xfce4-weather-plugin-0.8.3-1.fc18
Comment 13 Fedora Update System 2013-04-29 06:11:02 EDT
xfce4-weather-plugin-0.8.3-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xfce4-weather-plugin-0.8.3-1.fc17
Comment 14 Fedora Update System 2013-04-29 23:24:36 EDT
Package xfce4-weather-plugin-0.8.3-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xfce4-weather-plugin-0.8.3-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6981/xfce4-weather-plugin-0.8.3-1.fc18
then log in and leave karma (feedback).
Comment 15 sky.rim08 2013-05-02 16:09:08 EDT
Thank you for the update. I agree with you on that part not being clear enough and was about to drop the dev a mail to reword that section of the documentation and be more explanative. But looking at current git, that has already happened.
Comment 16 Fedora Update System 2013-05-07 20:26:01 EDT
xfce4-weather-plugin-0.8.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xfce4-weather-plugin-0.8.3-1.fc19
Comment 17 Fedora Update System 2013-05-18 22:35:49 EDT
xfce4-weather-plugin-0.8.3-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2013-05-18 22:44:29 EDT
xfce4-weather-plugin-0.8.3-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2013-05-24 16:51:21 EDT
xfce4-weather-plugin-0.8.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.