Bug 948146

Summary: zabbix server doesn't start if zabbix agent is installed on the same machine
Product: [Fedora] Fedora Reporter: cristi falcas <cristi.falcas>
Component: zabbixAssignee: Dan Horák <dan>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 18CC: brett.lentz, cristi.falcas, dan, nelsonab, volker27
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-04-04 10:22:09 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description cristi falcas 2013-04-04 07:01:05 UTC
Description of problem:
zabbix server doesn't start if zabbix agent is installed on the same machine

Version-Release number of selected component (if applicable):
2.0.5-1

How reproducible:
always

Steps to Reproduce:
1. install zabbix-agent
2. install zabbix-server
3. start agent and server
  
Actual results:
agent starts successfully
server doesn't start

Expected results:
both agent and server start successfully

Additional info:
The problem is that server has user/group zabbixsrv and agent zabbix

The default log dir and run dir is the same for both, but has mode 755 and owner zabbix.

Error:
zabbix_server [909]: cannot create PID file [/var/run/zabbix/zabbix_server.pid]: [13] Permission denied

Either the server should have other dirs own by zabbixsrv, or zabbixsrv should be in group zabbix and the above dirs have mode 775

Comment 1 Volker Fröhlich 2013-04-04 10:22:09 UTC
I hope I'll get to that soon.

*** This bug has been marked as a duplicate of bug 904041 ***