Bug 948146 - zabbix server doesn't start if zabbix agent is installed on the same machine
Summary: zabbix server doesn't start if zabbix agent is installed on the same machine
Keywords:
Status: CLOSED DUPLICATE of bug 904041
Alias: None
Product: Fedora
Classification: Fedora
Component: zabbix
Version: 18
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Dan Horák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-04 07:01 UTC by cristi falcas
Modified: 2013-04-04 10:22 UTC (History)
5 users (show)

Fixed In Version:
Clone Of:
Environment:
Last Closed: 2013-04-04 10:22:09 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description cristi falcas 2013-04-04 07:01:05 UTC
Description of problem:
zabbix server doesn't start if zabbix agent is installed on the same machine

Version-Release number of selected component (if applicable):
2.0.5-1

How reproducible:
always

Steps to Reproduce:
1. install zabbix-agent
2. install zabbix-server
3. start agent and server
  
Actual results:
agent starts successfully
server doesn't start

Expected results:
both agent and server start successfully

Additional info:
The problem is that server has user/group zabbixsrv and agent zabbix

The default log dir and run dir is the same for both, but has mode 755 and owner zabbix.

Error:
zabbix_server [909]: cannot create PID file [/var/run/zabbix/zabbix_server.pid]: [13] Permission denied

Either the server should have other dirs own by zabbixsrv, or zabbixsrv should be in group zabbix and the above dirs have mode 775

Comment 1 Volker Fröhlich 2013-04-04 10:22:09 UTC
I hope I'll get to that soon.

*** This bug has been marked as a duplicate of bug 904041 ***


Note You need to log in before you can comment on or make changes to this bug.