Bug 949832

Summary: cloud-init fails to show network information correctly
Product: [Fedora] Fedora Reporter: Juerg Haefliger <juergh>
Component: cloud-initAssignee: Andrew Thomas <anthomas>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: apevec, ddumas, gholms, Jan.van.Eldik, jpopelka, kchamart, mattdm, shardy
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-06-14 14:58:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Juerg Haefliger 2013-04-09 06:35:00 UTC
cloud-init fails to display networking information on boot in an OpenStack environment. I.e., the following is displayed even though the network is up at that time:

Cloud-init v. 0.7.1 running 'init' at Tue, 09 Apr 2013 06:25:05 +0000. Up 9.91 ci-info: ++++++++++++++++Net device info+++++++++++++++++
ci-info: +--------+-------+---------+------+------------+
ci-info: | Device |   Up  | Address | Mask | Hw-Address |
ci-info: +--------+-------+---------+------+------------+
ci-info: |  lo:   | False |    .    |  .   |     .      |
ci-info: | eth0:  | False |    .    |  .   |     .      |
ci-info: +--------+-------+---------+------+------------+
ci-info: ++++++++++++++++++++++++++++++Route info++++++++++++++++++++++++++++++
ci-info: +-------+-------------+----------+---------------+-----------+-------+
ci-info: | Route | Destination | Gateway  |    Genmask    | Interface | Flags |
ci-info: +-------+-------------+----------+---------------+-----------+-------+
ci-info: |   0   |   0.0.0.0   | 10.0.0.1 |    0.0.0.0    |    eth0   |   UG  |
ci-info: |   1   |   10.0.0.0  | 0.0.0.0  | 255.255.255.0 |    eth0   |   U   |
ci-info: |   2   | 169.254.0.0 | 0.0.0.0  |  255.255.0.0  |    eth0   |   U   |
ci-info: +-------+-------------+----------+---------------+-----------+-------+

I believe the problem is in cloudinit/netinfo.py due to the fact the output of 'ifconfig -a' in Fedora 18 is different from other distros.

Comment 1 Matthew Miller 2013-05-24 11:27:31 UTC
Also, we might not even _have_ ifconfig. (net-tools is a leaf package.) It would be better to use 'ip' (from iproute, which is a core dependency.

Comment 2 Matthew Miller 2013-06-14 14:58:03 UTC

*** This bug has been marked as a duplicate of bug 786488 ***

Comment 3 Jiri Popelka 2013-06-14 15:02:53 UTC
(In reply to Juerg Haefliger from comment #0)
> of 'ifconfig -a' in Fedora 18 is different from other distros.

That's right, see bug #784314