This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 955389

Summary: SELinux is preventing systemd-journal from 'use' accesses on the fd fd.
Product: [Fedora] Fedora Reporter: Moez Roy <moez.roy>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: dominick.grift, dwalsh, mgrepl
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:f4b8ce48a0a5f903373d276916b69a085ad65fac447fc453541abe0fc5d4784f
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-04-23 04:11:17 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Moez Roy 2013-04-22 19:51:05 EDT
Description of problem:
SELinux is preventing systemd-journal from 'use' accesses on the fd fd.

*****  Plugin catchall_boolean (89.3 confidence) suggests  *******************

If you want to allow all domains to use other domains file descriptors
Then you must tell SELinux about this by enabling the 'domain_fd_use' boolean.
You can read 'None' man page for more details.
Do
setsebool -P domain_fd_use 1

*****  Plugin catchall (11.6 confidence) suggests  ***************************

If you believe that systemd-journal should be allowed use access on the fd fd by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep systemd-journal /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:syslogd_t:s0
Target Context                system_u:system_r:kernel_t:s0
Target Objects                fd [ fd ]
Source                        systemd-journal
Source Path                   systemd-journal
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           systemd-201-2.fc18.5.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-91.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.8.8-202.fc18.x86_64 #1 SMP Wed
                              Apr 17 23:25:17 UTC 2013 x86_64 x86_64
Alert Count                   5
First Seen                    2013-04-22 16:17:40 PDT
Last Seen                     2013-04-22 16:17:41 PDT
Local ID                      3f67ad7b-822e-42b3-90e3-cee264dce9d5

Raw Audit Messages
type=AVC msg=audit(1366672661.279:516): avc:  denied  { use } for  pid=5491 comm="systemd-journal" path="socket:[6249]" dev="sockfs" ino=6249 scontext=system_u:system_r:syslogd_t:s0 tcontext=system_u:system_r:kernel_t:s0 tclass=fd


type=AVC msg=audit(1366672661.279:516): avc:  denied  { use } for  pid=5491 comm="systemd-journal" path="socket:[6252]" dev="sockfs" ino=6252 scontext=system_u:system_r:syslogd_t:s0 tcontext=system_u:system_r:kernel_t:s0 tclass=fd


type=AVC msg=audit(1366672661.279:516): avc:  denied  { use } for  pid=5491 comm="systemd-journal" path="socket:[6254]" dev="sockfs" ino=6254 scontext=system_u:system_r:syslogd_t:s0 tcontext=system_u:system_r:kernel_t:s0 tclass=fd


type=SYSCALL msg=audit(1366672661.279:516): arch=x86_64 syscall=execve success=yes exit=0 a0=7f1d37b304b0 a1=7f1d37a9a760 a2=7f1d37a9b1e0 a3=ffffffe0 items=0 ppid=1 pid=5491 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=systemd-journal exe=/usr/lib/systemd/systemd-journald subj=system_u:system_r:syslogd_t:s0 key=(null)

Hash: systemd-journal,syslogd_t,kernel_t,fd,use

audit2allow

#============= syslogd_t ==============
#!!!! This avc can be allowed using the boolean 'domain_fd_use'

allow syslogd_t kernel_t:fd use;

audit2allow -R
require {
	type syslogd_t;
}

#============= syslogd_t ==============
kernel_use_fds(syslogd_t)


Additional info:
hashmarkername: setroubleshoot
kernel:         3.8.8-202.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-04-23 04:08:39 EDT

*** This bug has been marked as a duplicate of bug 881577 ***
Comment 2 Miroslav Grepl 2013-04-23 04:11:17 EDT
Please run

# setsebool -P domain_fd_use 1
Comment 3 Miroslav Grepl 2013-04-23 04:11:26 EDT
*** Bug 955390 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2013-04-23 04:11:35 EDT
*** Bug 955391 has been marked as a duplicate of this bug. ***