This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 955390 - SELinux is preventing /usr/sbin/modem-manager from 'use' accesses on the fd /dev/pts/0.
SELinux is preventing /usr/sbin/modem-manager from 'use' accesses on the fd /...
Status: CLOSED DUPLICATE of bug 955389
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:b44c026f5c819871ade986e3eeb...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-22 19:52 EDT by Moez Roy
Modified: 2013-04-23 04:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-23 04:11:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-04-22 19:52:40 EDT
Description of problem:
SELinux is preventing /usr/sbin/modem-manager from 'use' accesses on the fd /dev/pts/0.

*****  Plugin catchall_boolean (89.3 confidence) suggests  *******************

If you want to allow all domains to use other domains file descriptors
Then you must tell SELinux about this by enabling the 'domain_fd_use' boolean.
You can read 'None' man page for more details.
Do
setsebool -P domain_fd_use 1

*****  Plugin catchall (11.6 confidence) suggests  ***************************

If you believe that modem-manager should be allowed use access on the 0 fd by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep modem-manager /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:modemmanager_t:s0-s0:c0.c1023
Target Context                system_u:system_r:kernel_t:s0
Target Objects                /dev/pts/0 [ fd ]
Source                        modem-manager
Source Path                   /usr/sbin/modem-manager
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           ModemManager-0.6.0.0-3.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-91.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.8.8-202.fc18.x86_64 #1 SMP Wed
                              Apr 17 23:25:17 UTC 2013 x86_64 x86_64
Alert Count                   6
First Seen                    2013-04-22 16:22:00 PDT
Last Seen                     2013-04-22 16:22:00 PDT
Local ID                      a446115f-cc31-4e05-ab1b-ab827bccc6a5

Raw Audit Messages
type=AVC msg=audit(1366672920.848:179): avc:  denied  { use } for  pid=898 comm="modem-manager" path="/dev/pts/0" dev="devpts" ino=3 scontext=system_u:system_r:modemmanager_t:s0-s0:c0.c1023 tcontext=system_u:system_r:kernel_t:s0 tclass=fd


type=SYSCALL msg=audit(1366672920.848:179): arch=x86_64 syscall=write success=no exit=EACCES a0=1a a1=7fa27a161000 a2=3b a3=3b items=0 ppid=1 pid=898 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=modem-manager exe=/usr/sbin/modem-manager subj=system_u:system_r:modemmanager_t:s0-s0:c0.c1023 key=(null)

Hash: modem-manager,modemmanager_t,kernel_t,fd,use

audit2allow

#============= modemmanager_t ==============
#!!!! This avc can be allowed using the boolean 'domain_fd_use'

allow modemmanager_t kernel_t:fd use;

audit2allow -R
require {
	type modemmanager_t;
}

#============= modemmanager_t ==============
kernel_use_fds(modemmanager_t)


Additional info:
hashmarkername: setroubleshoot
kernel:         3.8.8-202.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-04-23 04:08:42 EDT

*** This bug has been marked as a duplicate of bug 881577 ***
Comment 2 Miroslav Grepl 2013-04-23 04:11:26 EDT

*** This bug has been marked as a duplicate of bug 955389 ***

Note You need to log in before you can comment on or make changes to this bug.