Bug 957743

Summary: error building rubygem-gherkin-2.11.6-1.1.fc19 on ARM
Product: [Fedora] Fedora Reporter: Peter Robinson <pbrobinson>
Component: rubygem-gherkinAssignee: Michal Fojtik <mfojtik>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 19CC: bkabrda, clalancette, mfojtik
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-05-05 09:55:19 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 245418    

Description Peter Robinson 2013-04-29 08:45:03 EDT
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1755358

I'm getting the following error when trying to build rubygem-gherkin-2.11.6-1.1.fc19

+ /usr/lib/rpm/check-buildroot
+ /usr/lib/rpm/redhat/brp-compress
+ /usr/lib/rpm/redhat/brp-strip /usr/bin/strip
+ /usr/lib/rpm/redhat/brp-strip-comment-note /usr/bin/strip /usr/bin/objdump
+ /usr/lib/rpm/redhat/brp-strip-static-archive /usr/bin/strip
+ /usr/lib/rpm/brp-python-bytecompile /usr/bin/python 1
+ /usr/lib/rpm/redhat/brp-python-hardlink
+ /usr/lib/rpm/redhat/brp-java-repack-jars
Processing files: rubygem-gherkin-2.11.6-1.1.fc19.armv7hl
error: File must begin with "/": %{gem_extdir}
RPM build errors:
    File must begin with "/": %{gem_extdir}
Child return code was: 1
EXCEPTION: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target armv7hl --nodeps builddir/build/SPECS/rubygem-gherkin.spec']
Traceback (most recent call last):

Not sure why it's not triggering on x86
Comment 1 Bohuslav "Slavek" Kabrda 2013-04-29 08:52:38 EDT
You should build the latest - rubygem-gherkin-2.11.6-2.fc19, not rubygem-gherkin-2.11.6-1.1.fc19. Please try that and let me know if it works.
Comment 2 Peter Robinson 2013-04-29 09:01:18 EDT
Same error

http://arm.koji.fedoraproject.org/koji/buildinfo?buildID=129849
Comment 3 Bohuslav "Slavek" Kabrda 2013-04-29 09:17:36 EDT
Doesn't seem to be the same error:

BuildError: error building package (arch armv7hl), mock exited with status 30; see root.log for more information

And the root.log is not even there.
Comment 4 Peter Robinson 2013-04-29 12:14:19 EDT
Seems that I had to bootstrap it but it's now failing in check.

+ umask 022
~/build/BUILD/usr/share/gems/gems/gherkin-2.11.6 ~/build/BUILD
+ cd /builddir/build/BUILD
+ pushd ./usr/share/gems/gems/gherkin-2.11.6
+ export GEM_HOME=../../
+ GEM_HOME=../../
+ sed -i 7,8d features/support/env.rb
+ sed -i 7,8d spec/spec_helper.rb
++ cucumber --version
+ ln -s /usr/share/gems/gems/cucumber-1.2.1/ ../cucumber
+ LANG=en_US.utf8
+ cucumber
+ grep '16 failed'
error: Bad exit status from /var/tmp/rpm-tmp.rcrreL (%check)
    Bad exit status from /var/tmp/rpm-tmp.rcrreL (%check)
RPM build errors:
Child return code was: 1
EXCEPTION: Command failed. See logs for output.

http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1756770