Bug 957743 - error building rubygem-gherkin-2.11.6-1.1.fc19 on ARM
Summary: error building rubygem-gherkin-2.11.6-1.1.fc19 on ARM
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rubygem-gherkin
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Fojtik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2013-04-29 12:45 UTC by Peter Robinson
Modified: 2014-05-05 13:55 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-05-05 13:55:19 UTC


Attachments (Terms of Use)

Description Peter Robinson 2013-04-29 12:45:03 UTC
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1755358

I'm getting the following error when trying to build rubygem-gherkin-2.11.6-1.1.fc19

+ /usr/lib/rpm/check-buildroot
+ /usr/lib/rpm/redhat/brp-compress
+ /usr/lib/rpm/redhat/brp-strip /usr/bin/strip
+ /usr/lib/rpm/redhat/brp-strip-comment-note /usr/bin/strip /usr/bin/objdump
+ /usr/lib/rpm/redhat/brp-strip-static-archive /usr/bin/strip
+ /usr/lib/rpm/brp-python-bytecompile /usr/bin/python 1
+ /usr/lib/rpm/redhat/brp-python-hardlink
+ /usr/lib/rpm/redhat/brp-java-repack-jars
Processing files: rubygem-gherkin-2.11.6-1.1.fc19.armv7hl
error: File must begin with "/": %{gem_extdir}
RPM build errors:
    File must begin with "/": %{gem_extdir}
Child return code was: 1
EXCEPTION: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target armv7hl --nodeps builddir/build/SPECS/rubygem-gherkin.spec']
Traceback (most recent call last):

Not sure why it's not triggering on x86

Comment 1 Bohuslav "Slavek" Kabrda 2013-04-29 12:52:38 UTC
You should build the latest - rubygem-gherkin-2.11.6-2.fc19, not rubygem-gherkin-2.11.6-1.1.fc19. Please try that and let me know if it works.

Comment 2 Peter Robinson 2013-04-29 13:01:18 UTC
Same error

http://arm.koji.fedoraproject.org/koji/buildinfo?buildID=129849

Comment 3 Bohuslav "Slavek" Kabrda 2013-04-29 13:17:36 UTC
Doesn't seem to be the same error:

BuildError: error building package (arch armv7hl), mock exited with status 30; see root.log for more information

And the root.log is not even there.

Comment 4 Peter Robinson 2013-04-29 16:14:19 UTC
Seems that I had to bootstrap it but it's now failing in check.

+ umask 022
~/build/BUILD/usr/share/gems/gems/gherkin-2.11.6 ~/build/BUILD
+ cd /builddir/build/BUILD
+ pushd ./usr/share/gems/gems/gherkin-2.11.6
+ export GEM_HOME=../../
+ GEM_HOME=../../
+ sed -i 7,8d features/support/env.rb
+ sed -i 7,8d spec/spec_helper.rb
++ cucumber --version
+ ln -s /usr/share/gems/gems/cucumber-1.2.1/ ../cucumber
+ LANG=en_US.utf8
+ cucumber
+ grep '16 failed'
error: Bad exit status from /var/tmp/rpm-tmp.rcrreL (%check)
    Bad exit status from /var/tmp/rpm-tmp.rcrreL (%check)
RPM build errors:
Child return code was: 1
EXCEPTION: Command failed. See logs for output.

http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1756770


Note You need to log in before you can comment on or make changes to this bug.