Bug 965685

Summary: SysV init scripts support in bad shape in package
Product: [Fedora] Fedora EPEL Reporter: Simone Caronni <negativo17>
Component: dkmsAssignee: sunil <sunil_gupta2>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: el6CC: mario_limonciello, negativo17, sunil_gupta2, tcallawa
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: dkms-2.2.0.3-8.fc17 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-07-16 01:03:46 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 965712    

Description Simone Caronni 2013-05-21 14:37:07 UTC
Description of problem:
SysV init scripts in the package are not compliant to EPEL policies at:
http://fedoraproject.org/wiki/Packaging:SysVInitScript

No return codes, no lock file support, wrong package requirements, wrong scriptlets.

Version-Release number of selected component (if applicable):
dkms-2.2.0.3-2.el5
dkms-2.2.0.3-2.el6

How reproducible:
Always

Steps to Reproduce:
1. Install package
2. Enable service
3. Run "service dkms status"
4. Inspect package with "rpm -q --requires dkms"
5. Inspect SysV init file /etc/init.d/dkms_autoinstaller

Actual results:
No information is given, script does nothing on status check; no lock file support, no requirement on chkconfig or initscripts.

Expected results:
Everything should be compliant and package should pull in correct dependencies.

Additional info:
Package seems mostly abandoned.

Comment 1 Simone Caronni 2013-05-21 14:56:33 UTC
*** Bug 965675 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2013-06-20 11:22:21 UTC
dkms-2.2.0.3-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-7.fc19

Comment 3 Fedora Update System 2013-06-20 11:23:41 UTC
dkms-2.2.0.3-7.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-7.fc18

Comment 4 Fedora Update System 2013-06-20 11:25:29 UTC
dkms-2.2.0.3-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-7.fc17

Comment 5 Fedora Update System 2013-06-20 11:27:58 UTC
dkms-2.2.0.3-7.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-7.el6

Comment 6 Fedora Update System 2013-06-20 11:30:43 UTC
dkms-2.2.0.3-7.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-7.el5

Comment 7 Fedora Update System 2013-06-20 18:04:37 UTC
Package dkms-2.2.0.3-7.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dkms-2.2.0.3-7.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11369/dkms-2.2.0.3-7.fc19
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2013-06-26 07:21:41 UTC
dkms-2.2.0.3-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-8.fc19

Comment 9 Fedora Update System 2013-06-26 07:24:29 UTC
dkms-2.2.0.3-8.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-8.fc18

Comment 10 Fedora Update System 2013-06-26 07:29:25 UTC
dkms-2.2.0.3-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-8.fc17

Comment 11 Fedora Update System 2013-06-26 07:32:25 UTC
dkms-2.2.0.3-8.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-8.el6

Comment 12 Fedora Update System 2013-06-26 07:33:47 UTC
dkms-2.2.0.3-8.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/dkms-2.2.0.3-8.el5

Comment 13 Fedora Update System 2013-07-16 01:03:46 UTC
dkms-2.2.0.3-8.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2013-07-16 01:08:27 UTC
dkms-2.2.0.3-8.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2013-07-16 01:25:15 UTC
dkms-2.2.0.3-8.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2013-07-16 01:41:24 UTC
dkms-2.2.0.3-8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2013-07-16 01:47:42 UTC
dkms-2.2.0.3-8.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.