Bug 965675 - SysV init scripts definitions really in bad shape in package
SysV init scripts definitions really in bad shape in package
Status: CLOSED DUPLICATE of bug 965685
Product: Fedora
Classification: Fedora
Component: dkms (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: sunil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 10:04 EDT by Simone Caronni
Modified: 2013-05-21 10:56 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-21 10:56:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simone Caronni 2013-05-21 10:04:56 EDT
Description of problem:
Package does not contain correct Requires init requirements for the included SysV init scripts and %post, %preun sections are wrong and not conformant to packaging guidelines.

Version-Release number of selected component (if applicable):
dkms-2.2.0.3-5.fc19
dkms-2.2.0.3-2.el6
dkms-2.2.0.3-2.el5

How reproducible:
Always

Steps to Reproduce:
1. Browse to http://pkgs.fedoraproject.org/cgit/dkms.git/tree/dkms.spec
2. Compare to http://fedoraproject.org/wiki/Packaging:SysVInitScript

Actual results:
Package contains wrong requirements and wrong %post, %preun sections even for EPEL 5/6.

Expected results:
Package should work properly and be compliant with the packaging guidelines.

Additional info:
Package seems mostly abandoned.
Comment 1 Simone Caronni 2013-05-21 10:56:33 EDT

*** This bug has been marked as a duplicate of bug 965685 ***

Note You need to log in before you can comment on or make changes to this bug.