Bug 1000018 - terminal emulators don't work after update to glibc-2.17-13.fc19
terminal emulators don't work after update to glibc-2.17-13.fc19
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Carlos O'Donell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 09:59 EDT by Dragos Tatulea
Modified: 2016-11-24 10:59 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-23 04:19:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
urxvt strace log (118.99 KB, text/x-log)
2013-08-22 09:59 EDT, Dragos Tatulea
no flags Details

  None (edit)
Description Dragos Tatulea 2013-08-22 09:59:08 EDT
Created attachment 789211 [details]
urxvt strace log

Description of problem:
After doing a yum upgrade, most terminal emulators don't want to start (gnome-terminal, urxvt, tmux)

Version-Release number of selected component (if applicable):
glibc-2.17-13.fc19

How reproducible:
Just start urxvt, tmux, gnome-terminal.

Steps to Reproduce:
1. run urxvt

Actual results:
urxvt: can't initialize pseudo-tty, aborting.

Expected results:
urxvt starts without errors

Additional info:

* Narrowed it down to glibc. There's a pty chown CVE fix in there [1]

* After downgrading glibc, everything is back to normal.

* Here's how devpts is mounted:
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600,ptmxmode=000)

* Attached strace log. Check out the chown err on /dev/pts/1.

[1] - https://admin.fedoraproject.org/updates/FEDORA-2013-15053/glibc-2.17-13.fc19?_csrf_token=390be9769cd733681beb5e86c521ebc6eabb6de6
Comment 1 Siddhesh Poyarekar 2013-08-22 10:42:29 EDT
devpts is mounted by default as:

devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,seclabel,gid=5,mode=620,ptmxmode=000)

Not having gid=5 in your mount options is wrong and should not occur in a default installation.  In fact, I had mentioned that in a note in the update link you posted.

Unless there is reason to believe that the default fedora install options resulted in gid=5 not being present, this is not a bug.  Do you know how your system ended up without gid=5 in the mount options?
Comment 2 Dragos Tatulea 2013-08-23 04:19:34 EDT
Ooops. PEBCAK. Found the issue: I deleted the devpts line in fstab and it was getting mounted with default arguments. After fixing that all works fine.

Note You need to log in before you can comment on or make changes to this bug.