Bug 1000026 - [RFE] tftp booleans for NFS/CIFS access
[RFE] tftp booleans for NFS/CIFS access
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
: 1000029 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 10:05 EDT by jcpunk
Modified: 2013-08-27 06:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 955774
Environment:
Last Closed: 2013-08-27 06:53:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jcpunk 2013-08-22 10:05:40 EDT
+++ This bug was initially created as a clone of Bug #955774 +++

Description of problem: I would very much like to provide some nfs content over tftp.  There is no way to enable that functionality with the current policy.  I've attached a patch which provides booleans for toggling that ability.  While I was in there I created some for CIFS as well.


Version-Release number of selected component (if applicable):3.12.1-71.fc19


How reproducible: 100%


Steps to Reproduce:
1. mount nfs share under tftp root
2. attempt to read the file
3. locate avc denied error
  
Actual results: permission denied


Expected results: the ability to easily configure selinux to read NFS files when I want it to.


Additional info:

--- Additional comment from Miroslav Grepl on 2013-08-06 03:40:34 EDT ---

Thank you for your patch. Added.
Comment 1 Miroslav Grepl 2013-08-27 06:53:33 EDT
In Fedora/RHEL7,

use_samba_home_dirs
use_nfs_home_dirs

should be enough to make it working.
Comment 2 Miroslav Grepl 2013-08-27 06:54:25 EDT
*** Bug 1000029 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.