Bug 1000030 - Move newer libproxy to the base channel
Move newer libproxy to the base channel
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Lubos Kocman
Release Test Team
:
Depends On:
Blocks: 972747
  Show dependency treegraph
 
Reported: 2013-08-22 10:10 EDT by Jan Stodola
Modified: 2015-05-15 06:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-15 06:47:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum update (193.19 KB, text/plain)
2013-08-22 10:22 EDT, Jan Stodola
no flags Details

  None (edit)
Description Jan Stodola 2013-08-22 10:10:44 EDT
Description of problem:
rhel-x86_64-hpc-node-optional-6 contains libproxy packages in version 0.3.0-4.el6_3
rhel-x86_64-hpc-node-6 contains libproxy packages in version 0.3.0-3.el6_3 (older than the version from optional)

Affected packages:
libproxy
libproxy-bin
libproxy-python

In RHEL-6.2 and 6.3, libproxy packages were available only in optional repository. In RHEL-6.4, libproxy packages mentioned above moved to base repository.
Since the packages are in base repository in RHEL-6.4, I believe that all updates for these packages should be delivered by base channel, not by the optional.

How reproducible:
always

Steps to Reproduce:
1. install RHEL-6.3 / ComputeNode / x86_64 @everything
2. register to rhn
3. subscribe to following channels:
* rhel-x86_64-hpc-node-6
* rhel-x86_64-hpc-node-optional-6
4. run 'yum update'

Actual results:
Latest versions of libproxy, libproxy-bin and libproxy-python are available from the optional channel

Expected results:
Latest versions of libproxy, libproxy-bin and libproxy-python are available from the base channel
Comment 2 Jan Stodola 2013-08-22 10:22:11 EDT
Created attachment 789215 [details]
yum update
Comment 3 RHEL Product and Program Management 2013-10-13 22:36:28 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Lubos Kocman 2015-05-15 06:47:40 EDT
I believe that this one can be closed since there is a newer libproxy update which is already in non-optional repos.

[lkocman@rcm-dev SRPMS]$ locate-rpms libproxy | grep bin
Client/i386/os/Packages/libproxy-bin-0.3.0-10.el6.i686.rpm
Client/x86_64/os/Packages/libproxy-bin-0.3.0-10.el6.x86_64.rpm
ComputeNode/x86_64/os/Packages/libproxy-bin-0.3.0-10.el6.x86_64.rpm
Server/i386/os/Packages/libproxy-bin-0.3.0-10.el6.i686.rpm
Server/ppc64/os/Packages/libproxy-bin-0.3.0-10.el6.ppc64.rpm
Server/s390x/os/Packages/libproxy-bin-0.3.0-10.el6.s390x.rpm
Server/x86_64/os/Packages/libproxy-bin-0.3.0-10.el6.x86_64.rpm
Workstation/i386/os/Packages/libproxy-bin-0.3.0-10.el6.i686.rpm
Workstation/x86_64/os/Packages/libproxy-bin-0.3.0-10.el6.x86_64.rpm

[lkocman@rcm-dev SRPMS]$ locate-rpms libproxy | grep python
Client/i386/os/Packages/libproxy-python-0.3.0-10.el6.i686.rpm
Client/x86_64/os/Packages/libproxy-python-0.3.0-10.el6.x86_64.rpm
ComputeNode/x86_64/os/Packages/libproxy-python-0.3.0-10.el6.x86_64.rpm
Server/i386/os/Packages/libproxy-python-0.3.0-10.el6.i686.rpm
Server/ppc64/os/Packages/libproxy-python-0.3.0-10.el6.ppc64.rpm
Server/s390x/os/Packages/libproxy-python-0.3.0-10.el6.s390x.rpm
Server/x86_64/os/Packages/libproxy-python-0.3.0-10.el6.x86_64.rpm
Workstation/i386/os/Packages/libproxy-python-0.3.0-10.el6.i686.rpm
Workstation/x86_64/os/Packages/libproxy-python-0.3.0-10.el6.x86_64.rpm

[lkocman@rcm-dev SRPMS]$ locate-rpms libproxy | grep libproxy-0
Client/i386/os/Packages/libproxy-0.3.0-10.el6.i686.rpm
Client/source/SRPMS/libproxy-0.3.0-10.el6.src.rpm
Client/x86_64/os/Packages/libproxy-0.3.0-10.el6.i686.rpm
Client/x86_64/os/Packages/libproxy-0.3.0-10.el6.x86_64.rpm
ComputeNode/source/SRPMS/libproxy-0.3.0-10.el6.src.rpm
ComputeNode/x86_64/os/Packages/libproxy-0.3.0-10.el6.i686.rpm
ComputeNode/x86_64/os/Packages/libproxy-0.3.0-10.el6.x86_64.rpm
Server/i386/os/Packages/libproxy-0.3.0-10.el6.i686.rpm
Server/ppc64/os/Packages/libproxy-0.3.0-10.el6.ppc.rpm
Server/ppc64/os/Packages/libproxy-0.3.0-10.el6.ppc64.rpm
Server/s390x/os/Packages/libproxy-0.3.0-10.el6.s390.rpm
Server/s390x/os/Packages/libproxy-0.3.0-10.el6.s390x.rpm
Server/source/SRPMS/libproxy-0.3.0-10.el6.src.rpm
Server/x86_64/os/Packages/libproxy-0.3.0-10.el6.i686.rpm
Server/x86_64/os/Packages/libproxy-0.3.0-10.el6.x86_64.rpm
Workstation/i386/os/Packages/libproxy-0.3.0-10.el6.i686.rpm
Workstation/source/SRPMS/libproxy-0.3.0-10.el6.src.rpm
Workstation/x86_64/os/Packages/libproxy-0.3.0-10.el6.i686.rpm
Workstation/x86_64/os/Packages/libproxy-0.3.0-10.el6.x86_64.rpm

Note You need to log in before you can comment on or make changes to this bug.