Bug 1000040 - verify current PGP public key expires later than 2014
verify current PGP public key expires later than 2014
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Lestach
Dimitar Yordanov
:
Depends On:
Blocks: sat560-blockers
  Show dependency treegraph
 
Reported: 2013-08-22 10:38 EDT by Tomas Lestach
Modified: 2013-10-01 17:55 EDT (History)
2 users (show)

See Also:
Fixed In Version: spacewalk-config-2.1.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:55:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Lestach 2013-08-22 10:38:58 EDT
Description of problem:
Because current PGP public key expires 2014-02-15, we need to replace it with a newer one.

Version-Release number of selected component (if applicable):
sat560

How reproducible:
always

Steps to Reproduce:
1. check, when the current PGP key expires
2. make sure rhn-satellite-activate (that checks the entitlement certificate signature) works

Actual results:
# gpg --list-keys --no-default-keyring --keyring /etc/webapp-keyring.gpg
/etc/webapp-keyring.gpg.org
---------------------------
pub   1024D/06947932 2004-02-18 [expires: 2014-02-15]
uid                  Red Hat Network (Satellite Certificate Signing Key) <rhn-feedback@redhat.com>
sub   2048g/C71F2F5C 2004-02-18 [expires: 2014-02-15]

Expected results:
# gpg --list-keys --no-default-keyring --keyring /etc/webapp-keyring.gpg
/etc/webapp-keyring.gpg
-----------------------
pub   1024D/06947932 2004-02-18 [expires: 2023-02-05]
uid                  Red Hat Network (Satellite Certificate Signing Key) <rhn-feedback@redhat.com>
sub   2048g/C71F2F5C 2004-02-18 [expires: 2023-02-05]

Additional info:
Just note Bug 1000027
Comment 2 Tomas Lestach 2013-08-22 10:43:27 EDT
spacewalk.git: 76d6c80fe8edc2e86cd7d8f4b4bd854b8c884cea
Comment 10 Clifford Perry 2013-10-01 17:55:55 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.