Bug 1000068 - [TEXT] change "Cannot run VM. The VM status is illegal." to "Cannot run VM. The VM is already running"
[TEXT] change "Cannot run VM. The VM status is illegal." to "Cannot run VM. T...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Tomas Jelinek
Artyom
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 11:26 EDT by Andrew Cathrow
Modified: 2014-09-07 18:56 EDT (History)
9 users (show)

See Also:
Fixed In Version: is18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:19:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19211 None None None Never
oVirt gerrit 19766 None None None Never

  None (edit)
Description Andrew Cathrow 2013-08-22 11:26:07 EDT
Change text as described in $summary
Comment 1 Michal Skrivanek 2013-08-23 05:13:36 EDT
this particular message is used in various places, where exactly did it happen to you?
Comment 2 Andrew Cathrow 2013-08-23 07:29:00 EDT
(In reply to Michal Skrivanek from comment #1)
> this particular message is used in various places, where exactly did it
> happen to you?

Start a VM
The refresh was slow to happen (go figure?)
Press start again
Comment 3 Tomas Jelinek 2013-09-12 09:36:03 EDT
There are lots of states the VM can be in in which the VM can not start (resulting in the message: Cannot run VM. The VM status is illegal.). Namely:

WaitForLaunch, Up, PoweringDown, PoweringUp, RebootInProgress, MigratingFrom, SavingState, PreparingForHibernate, RestoringState, ImageIllegal, ImageLocked, NotResponding, Unassigned, Unknown

What granularity do we want? Do we want only the "Up" to return a different message? Or we could change the message to something like:

"Cannot run VM because it is in ${status} status."

Andrew?
Comment 4 Andrew Cathrow 2013-09-12 09:46:28 EDT
(In reply to Tomas Jelinek from comment #3)
> There are lots of states the VM can be in in which the VM can not start
> (resulting in the message: Cannot run VM. The VM status is illegal.). Namely:
> 
> WaitForLaunch, Up, PoweringDown, PoweringUp, RebootInProgress,
> MigratingFrom, SavingState, PreparingForHibernate, RestoringState,
> ImageIllegal, ImageLocked, NotResponding, Unassigned, Unknown
> 
> What granularity do we want? Do we want only the "Up" to return a different
> message? Or we could change the message to something like:
> 
> "Cannot run VM because it is in ${status} status."
> 
> Andrew?

We should give the clearest answer to the end user. Having the customized message per status as above would be the best approach.

Would these messages be translated or would just show "PoweringUp" -vs- "Powering Up"
Comment 5 Tomas Jelinek 2013-09-12 10:27:25 EDT
> Would these messages be translated or would just show "PoweringUp" -vs- 
> "Powering Up"

There is a support to make them localized so they could be like "Powering Up".
Comment 6 Artyom 2013-09-27 02:31:43 EDT
Fast click on run vm give error message "Cannot run VM because it is in Wair for Launch status."
Please correct from "Wair" to "Wait"
After second run button disabled.
Comment 7 Artyom 2013-09-27 02:32:11 EDT
Checked on is16
Comment 8 Artyom 2013-10-10 03:14:47 EDT
Verified on is18
Comment 9 Itamar Heim 2014-01-21 17:19:11 EST
Closing - RHEV 3.3 Released
Comment 10 Itamar Heim 2014-01-21 17:25:23 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.