Bug 1000075 - Yum update to "glusterfs-3.4.0.22rhs-1" is failing as glusterfs-libs-3.4.0.22rhs-1.el6rhs.x86_64 requires rsyslog-mmcount
Yum update to "glusterfs-3.4.0.22rhs-1" is failing as glusterfs-libs-3.4.0.22...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.1
Unspecified Unspecified
high Severity urgent
: ---
: ---
Assigned To: Bala.FA
Lalatendu Mohanty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 11:31 EDT by Lalatendu Mohanty
Modified: 2015-11-22 21:57 EST (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.22rhs-2.el6rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:36:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lalatendu Mohanty 2013-08-22 11:31:46 EDT
Description of problem:

Yum update to "glusterfs-3.4.0.22rhs-1" is failing as glusterfs-libs-3.4.0.22rhs-1.el6rhs.x86_64 requires rsyslog-mmcount

Also "yum install rsyslog-mmcount" don't fetch any packages

[root@bvt-rhs3 yum.repos.d]# yum update glusterfs
Loaded plugins: aliases, changelog, downloadonly, fastestmirror, filter-data, keys, list-
              : data, merge-conf, priorities, product-id, protectbase, rhnplugin, security,
              : subscription-manager, tmprepo, tsflags, upgrade-helper, verify, versionlock
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
Loading mirror speeds from cached hostfile
rhel-x86_64-server-6.4.z                                              | 1.8 kB     00:00     
rhel-x86_64-server-6.4.z/primary                                      |  14 MB     00:20     
rhel-x86_64-server-6.4.z                                                         10835/10835
rhs2.1-server                                                         | 2.9 kB     00:00     
rhs2.1-server/primary_db                                              | 8.4 kB     00:00     
Skipping filters plugin, no data
0 packages excluded due to repository protections
Setting up Update Process
Resolving Dependencies
Skipping filters plugin, no data
--> Running transaction check
---> Package glusterfs.x86_64 0:3.4.0.19rhs-2.el6rhs will be updated
--> Processing Dependency: glusterfs = 3.4.0.19rhs-2.el6rhs for package: glusterfs-rdma-3.4.0.19rhs-2.el6rhs.x86_64
--> Processing Dependency: glusterfs = 3.4.0.19rhs-2.el6rhs for package: glusterfs-server-3.4.0.19rhs-2.el6rhs.x86_64
--> Processing Dependency: glusterfs = 3.4.0.19rhs-2.el6rhs for package: glusterfs-fuse-3.4.0.19rhs-2.el6rhs.x86_64
--> Processing Dependency: glusterfs = 3.4.0.19rhs-2.el6rhs for package: glusterfs-geo-replication-3.4.0.19rhs-2.el6rhs.x86_64
---> Package glusterfs.x86_64 0:3.4.0.22rhs-1.el6rhs will be an update
--> Processing Dependency: glusterfs-libs = 3.4.0.22rhs-1.el6rhs for package: glusterfs-3.4.0.22rhs-1.el6rhs.x86_64
--> Running transaction check
---> Package glusterfs-fuse.x86_64 0:3.4.0.19rhs-2.el6rhs will be updated
---> Package glusterfs-fuse.x86_64 0:3.4.0.22rhs-1.el6rhs will be an update
---> Package glusterfs-geo-replication.x86_64 0:3.4.0.19rhs-2.el6rhs will be updated
---> Package glusterfs-geo-replication.x86_64 0:3.4.0.22rhs-1.el6rhs will be an update
---> Package glusterfs-libs.x86_64 0:3.4.0.19rhs-2.el6rhs will be updated
--> Processing Dependency: glusterfs-libs = 3.4.0.19rhs-2.el6rhs for package: glusterfs-api-3.4.0.19rhs-2.el6rhs.x86_64
---> Package glusterfs-libs.x86_64 0:3.4.0.22rhs-1.el6rhs will be an update
--> Processing Dependency: rsyslog-mmcount for package: glusterfs-libs-3.4.0.22rhs-1.el6rhs.x86_64
---> Package glusterfs-rdma.x86_64 0:3.4.0.19rhs-2.el6rhs will be updated
---> Package glusterfs-rdma.x86_64 0:3.4.0.22rhs-1.el6rhs will be an update
---> Package glusterfs-server.x86_64 0:3.4.0.19rhs-2.el6rhs will be updated
---> Package glusterfs-server.x86_64 0:3.4.0.22rhs-1.el6rhs will be an update
--> Running transaction check
---> Package glusterfs-api.x86_64 0:3.4.0.19rhs-2.el6rhs will be updated
---> Package glusterfs-api.x86_64 0:3.4.0.22rhs-1.el6rhs will be an update
---> Package glusterfs-libs.x86_64 0:3.4.0.22rhs-1.el6rhs will be an update
--> Processing Dependency: rsyslog-mmcount for package: glusterfs-libs-3.4.0.22rhs-1.el6rhs.x86_64
--> Finished Dependency Resolution
Error: Package: glusterfs-libs-3.4.0.22rhs-1.el6rhs.x86_64 (rhs2.1-server)
           Requires: rsyslog-mmcount
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@bvt-rhs3 yum.repos.d]# rpm -qa | grep rsyslog-mmcount
[root@bvt-rhs3 yum.repos.d]# yum search rsyslog-mmcount
Loaded plugins: aliases, changelog, downloadonly, fastestmirror, filter-data, keys, list-
              : data, merge-conf, priorities, product-id, protectbase, rhnplugin, security,
              : subscription-manager, tmprepo, tsflags, upgrade-helper, verify, versionlock
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
Loading mirror speeds from cached hostfile
0 packages excluded due to repository protections
Warning: No matches found for: rsyslog-mmcount


root@bvt-rhs3 yum.repos.d]# yum install rsyslog-mmcount
Loaded plugins: aliases, changelog, downloadonly, fastestmirror, filter-data, keys, list-data, merge-conf, priorities, product-id, protectbase, rhnplugin, security, subscription-manager,
              : tmprepo, tsflags, upgrade-helper, verify, versionlock
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
Loading mirror speeds from cached hostfile
Skipping filters plugin, no data
0 packages excluded due to repository protections
Setting up Install Process
No package rsyslog-mmcount available.
Error: Nothing to do


How reproducible:

Always

Actual results:


Expected results:


Additional info:
Comment 1 Ben Turner 2013-08-22 11:45:11 EDT
Installation is also failing from ISO via beaker:

Retrieving installation information for beaker-RHS.
Retrieving installation information for beaker-debuginfo.
Retrieving installation information for rhs.
Checking dependencies in packages selected for installation
In progress
Completed

Starting installation process
In progress

Installing glusterfs-libs-3.4.0.22rhs-1.el6rhs.x86_64 (694 KB)
GlusterFS common libraries
Command line mode requires all choices to be specified in a kickstart configuration file.
Error Installing Package
A fatal error occurred when installing the glusterfs-libs package.  This could indicate errors when reading the installation media.  Installation cannot continue.

It looks like we need to package rsyslog-mmcount in the ISO.
Comment 2 Ben Turner 2013-08-22 12:14:34 EDT
A couple notes from my research:

-rsyslog-mmcount is an rsyslog module developed by bala: http://www.rsyslog.com/doc/mmcount.html
-It is included in the 7.5 version.
-The latest RHEL 6.4 rsyslog is rsyslog-5.8.10-6.el6.x86_64
-The latest upstream and RHEL 7 is the 7.4 branch.

A good summary is here:

http://lists.gnu.org/archive/html/gluster-devel/2013-08/msg00039.html

It sounds like it has been backported to RHEL 6, "This module is back ported to rhel6 which does tracking and json parsing.".  I think we may just need to change the dependency to the rsyslog version with the backport instead of the rsyslog-mmcount package?
Comment 3 Rejy M Cyriac 2013-08-23 02:55:26 EDT
glusterfs-server.x86_64 0:3.4.0.21rhs-1.el6rhs to glusterfs-server.x86_64 0:3.4.0.22rhs-2.el6rhs works for me
Comment 4 Lalatendu Mohanty 2013-08-23 03:35:33 EDT
"yum update glusterfs" from "3.4.0.21rhs-1 to 3.4.0.22rhs-2" or from older rpms i .e "3.4.0.19rhs-2 to 3.4.0.22rhs-2" works fine for me , only if the gluster volume is in stopped state.

But if the gluster volume is in "Started" state. The update to latest "3.4.0.22rhs-2 " from any previous builds fails with below error.

The process to stop the volume before yum update  is fine according to our rhs update policy. But for previous builds we were able to do the yum update even if the volume was in "started" state.

However the below error is not administrator friendly and can lead to lot of confusion. If we can add a small check in the pre-install scripts or somewhere , which will return some user/admin friendly error before the update process happens by yum. 


[root@bvt-rhs1 ~]# yum update glusterfs
Loaded plugins: aliases, changelog, downloadonly, fastestmirror, filter-data, keys, list-data, merge-conf, priorities, product-id, protectbase, rhnplugin, security, subscription-manager,
              : tmprepo, tsflags, upgrade-helper, verify, versionlock
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
Loading mirror speeds from cached hostfile
rhs2.1-server                                                                                                                                                          | 2.9 kB     00:00     
rhs2.1-server/primary_db                                                                                                                                               | 8.1 kB     00:00     
Skipping filters plugin, no data
0 packages excluded due to repository protections
Setting up Update Process
Resolving Dependencies
Skipping filters plugin, no data
--> Running transaction check
---> Package glusterfs.x86_64 0:3.4.0.21rhs-1.el6rhs will be updated
--> Processing Dependency: glusterfs = 3.4.0.21rhs-1.el6rhs for package: glusterfs-server-3.4.0.21rhs-1.el6rhs.x86_64
--> Processing Dependency: glusterfs = 3.4.0.21rhs-1.el6rhs for package: glusterfs-rdma-3.4.0.21rhs-1.el6rhs.x86_64
--> Processing Dependency: glusterfs = 3.4.0.21rhs-1.el6rhs for package: glusterfs-geo-replication-3.4.0.21rhs-1.el6rhs.x86_64
--> Processing Dependency: glusterfs = 3.4.0.21rhs-1.el6rhs for package: glusterfs-fuse-3.4.0.21rhs-1.el6rhs.x86_64
---> Package glusterfs.x86_64 0:3.4.0.22rhs-2.el6rhs will be an update
--> Processing Dependency: glusterfs-libs = 3.4.0.22rhs-2.el6rhs for package: glusterfs-3.4.0.22rhs-2.el6rhs.x86_64
--> Running transaction check
---> Package glusterfs-fuse.x86_64 0:3.4.0.21rhs-1.el6rhs will be updated
---> Package glusterfs-fuse.x86_64 0:3.4.0.22rhs-2.el6rhs will be an update
---> Package glusterfs-geo-replication.x86_64 0:3.4.0.21rhs-1.el6rhs will be updated
---> Package glusterfs-geo-replication.x86_64 0:3.4.0.22rhs-2.el6rhs will be an update
---> Package glusterfs-libs.x86_64 0:3.4.0.21rhs-1.el6rhs will be updated
--> Processing Dependency: glusterfs-libs = 3.4.0.21rhs-1.el6rhs for package: glusterfs-api-3.4.0.21rhs-1.el6rhs.x86_64
---> Package glusterfs-libs.x86_64 0:3.4.0.22rhs-2.el6rhs will be an update
---> Package glusterfs-rdma.x86_64 0:3.4.0.21rhs-1.el6rhs will be updated
---> Package glusterfs-rdma.x86_64 0:3.4.0.22rhs-2.el6rhs will be an update
---> Package glusterfs-server.x86_64 0:3.4.0.21rhs-1.el6rhs will be updated
---> Package glusterfs-server.x86_64 0:3.4.0.22rhs-2.el6rhs will be an update
--> Running transaction check
---> Package glusterfs-api.x86_64 0:3.4.0.21rhs-1.el6rhs will be updated
---> Package glusterfs-api.x86_64 0:3.4.0.22rhs-2.el6rhs will be an update
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================================================================================================
 Package                                               Arch                               Version                                             Repository                                 Size
==============================================================================================================================================================================================
Updating:
 glusterfs                                             x86_64                             3.4.0.22rhs-2.el6rhs                                rhs2.1-server                             1.7 M
Updating for dependencies:
 glusterfs-api                                         x86_64                             3.4.0.22rhs-2.el6rhs                                rhs2.1-server                              39 k
 glusterfs-fuse                                        x86_64                             3.4.0.22rhs-2.el6rhs                                rhs2.1-server                              84 k
 glusterfs-geo-replication                             x86_64                             3.4.0.22rhs-2.el6rhs                                rhs2.1-server                             133 k
 glusterfs-libs                                        x86_64                             3.4.0.22rhs-2.el6rhs                                rhs2.1-server                             220 k
 glusterfs-rdma                                        x86_64                             3.4.0.22rhs-2.el6rhs                                rhs2.1-server                              40 k
 glusterfs-server                                      x86_64                             3.4.0.22rhs-2.el6rhs                                rhs2.1-server                             586 k

Transaction Summary
==============================================================================================================================================================================================
Upgrade       7 Package(s)

Total download size: 2.8 M
Is this ok [y/N]: y
Downloading Packages:
(1/7): glusterfs-3.4.0.22rhs-2.el6rhs.x86_64.rpm                                                                                                                       | 1.7 MB     00:00     
(2/7): glusterfs-api-3.4.0.22rhs-2.el6rhs.x86_64.rpm                                                                                                                   |  39 kB     00:00     
(3/7): glusterfs-fuse-3.4.0.22rhs-2.el6rhs.x86_64.rpm                                                                                                                  |  84 kB     00:00     
(4/7): glusterfs-geo-replication-3.4.0.22rhs-2.el6rhs.x86_64.rpm                                                                                                       | 133 kB     00:00     
(5/7): glusterfs-libs-3.4.0.22rhs-2.el6rhs.x86_64.rpm                                                                                                                  | 220 kB     00:00     
(6/7): glusterfs-rdma-3.4.0.22rhs-2.el6rhs.x86_64.rpm                                                                                                                  |  40 kB     00:00     
(7/7): glusterfs-server-3.4.0.22rhs-2.el6rhs.x86_64.rpm                                                                                                                | 586 kB     00:00     
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                          16 MB/s | 2.8 MB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Error in PRETRANS scriptlet in rpm package glusterfs-libs-3.4.0.22rhs-2.el6rhs.x86_64
Error in PRETRANS scriptlet in rpm package glusterfs-3.4.0.22rhs-2.el6rhs.x86_64
Error in PRETRANS scriptlet in rpm package glusterfs-fuse-3.4.0.22rhs-2.el6rhs.x86_64
Error in PRETRANS scriptlet in rpm package glusterfs-geo-replication-3.4.0.22rhs-2.el6rhs.x86_64
Error in PRETRANS scriptlet in rpm package glusterfs-server-3.4.0.22rhs-2.el6rhs.x86_64
Error in PRETRANS scriptlet in rpm package glusterfs-rdma-3.4.0.22rhs-2.el6rhs.x86_64
Error in PRETRANS scriptlet in rpm package glusterfs-api-3.4.0.22rhs-2.el6rhs.x86_64
  Verifying  : glusterfs-api-3.4.0.22rhs-2.el6rhs.x86_64                                                                                                                                 1/14 
  Verifying  : glusterfs-fuse-3.4.0.22rhs-2.el6rhs.x86_64                                                                                                                                2/14 
  Verifying  : glusterfs-libs-3.4.0.22rhs-2.el6rhs.x86_64                                                                                                                                3/14 
glusterfs-3.4.0.21rhs-1.el6rhs.x86_64 was supposed to be removed but is not!
  Verifying  : glusterfs-3.4.0.21rhs-1.el6rhs.x86_64                                                                                                                                     4/14 
glusterfs-api-3.4.0.21rhs-1.el6rhs.x86_64 was supposed to be removed but is not!
  Verifying  : glusterfs-api-3.4.0.21rhs-1.el6rhs.x86_64                                                                                                                                 5/14 
glusterfs-rdma-3.4.0.21rhs-1.el6rhs.x86_64 was supposed to be removed but is not!
  Verifying  : glusterfs-rdma-3.4.0.21rhs-1.el6rhs.x86_64                                                                                                                                6/14 
glusterfs-libs-3.4.0.21rhs-1.el6rhs.x86_64 was supposed to be removed but is not!
  Verifying  : glusterfs-libs-3.4.0.21rhs-1.el6rhs.x86_64                                                                                                                                7/14 
glusterfs-geo-replication-3.4.0.21rhs-1.el6rhs.x86_64 was supposed to be removed but is not!
  Verifying  : glusterfs-geo-replication-3.4.0.21rhs-1.el6rhs.x86_64                                                                                                                     8/14 
glusterfs-server-3.4.0.21rhs-1.el6rhs.x86_64 was supposed to be removed but is not!
  Verifying  : glusterfs-server-3.4.0.21rhs-1.el6rhs.x86_64                                                                                                                              9/14 
  Verifying  : glusterfs-geo-replication-3.4.0.22rhs-2.el6rhs.x86_64                                                                                                                    10/14 
glusterfs-fuse-3.4.0.21rhs-1.el6rhs.x86_64 was supposed to be removed but is not!
  Verifying  : glusterfs-fuse-3.4.0.21rhs-1.el6rhs.x86_64                                                                                                                               11/14 
  Verifying  : glusterfs-3.4.0.22rhs-2.el6rhs.x86_64                                                                                                                                    12/14 
  Verifying  : glusterfs-rdma-3.4.0.22rhs-2.el6rhs.x86_64                                                                                                                               13/14 
  Verifying  : glusterfs-server-3.4.0.22rhs-2.el6rhs.x86_64                                                                                                                             14/14 

Failed:
  glusterfs.x86_64 0:3.4.0.21rhs-1.el6rhs                           glusterfs.x86_64 0:3.4.0.22rhs-2.el6rhs                           glusterfs-api.x86_64 0:3.4.0.21rhs-1.el6rhs           
  glusterfs-api.x86_64 0:3.4.0.22rhs-2.el6rhs                       glusterfs-fuse.x86_64 0:3.4.0.21rhs-1.el6rhs                      glusterfs-fuse.x86_64 0:3.4.0.22rhs-2.el6rhs          
  glusterfs-geo-replication.x86_64 0:3.4.0.21rhs-1.el6rhs           glusterfs-geo-replication.x86_64 0:3.4.0.22rhs-2.el6rhs           glusterfs-libs.x86_64 0:3.4.0.21rhs-1.el6rhs          
  glusterfs-libs.x86_64 0:3.4.0.22rhs-2.el6rhs                      glusterfs-rdma.x86_64 0:3.4.0.21rhs-1.el6rhs                      glusterfs-rdma.x86_64 0:3.4.0.22rhs-2.el6rhs          
  glusterfs-server.x86_64 0:3.4.0.21rhs-1.el6rhs                    glusterfs-server.x86_64 0:3.4.0.22rhs-2.el6rhs                   





The above error is not at all user friendly and can lead to lot of confusion
Comment 5 Lalatendu Mohanty 2013-08-23 03:45:28 EDT
I will put a new bug for the error and marking this as verified
Comment 6 Scott Haines 2013-09-23 18:36:05 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.