Bug 1000081 - IllegalArgumentException: 1.3.6.1.4.1.2312.9.2.1952.null not an OID
IllegalArgumentException: 1.3.6.1.4.1.2312.9.2.1952.null not an OID
Status: CLOSED DUPLICATE of bug 997970
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: candlepin-bugs
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 11:44 EDT by Dennis Crissman
Modified: 2015-05-14 10:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-23 14:31:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
string 1.3.6.1.4.1.2312.9.2.1952.null not an OID error (52.93 KB, image/png)
2013-08-22 12:04 EDT, sthirugn@redhat.com
no flags Details

  None (edit)
Description Dennis Crissman 2013-08-22 11:44:01 EDT
Found this exception several times in a row in the candlepin stage logs. I am uncertain how it would be reproduced.

Aug 22 11:35:13 [ITClusteredScheduler_Worker-5] ERROR org.candlepin.pinsetter.core.PinsetterJobListener - Job [bind_by_pool_090abc3b-6277-4645-a1d2-97e8f99c5bdf] failed.
org.quartz.JobExecutionException: java.lang.IllegalArgumentException: string 1.3.6.1.4.1.2312.9.2.1952.null not an OID [See nested exception: java.lang.RuntimeException: java.lang.IllegalArgumentException: string 1.3.6.1.4.1.2312.9.2.1952.null not an OID]
	at org.candlepin.pinsetter.tasks.EntitlerJob.execute(EntitlerJob.java:77)
	at org.candlepin.pinsetter.core.TransactionalPinsetterJob.execute(TransactionalPinsetterJob.java:50)
	at org.quartz.core.JobRunShell.run(Unknown Source)
	at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(Unknown Source)
Caused by: java.lang.RuntimeException: java.lang.IllegalArgumentException: string 1.3.6.1.4.1.2312.9.2.1952.null not an OID
	at org.candlepin.controller.CandlepinPoolManager.generateEntitlementCertificate(CandlepinPoolManager.java:603)
	at org.candlepin.controller.CandlepinPoolManager.access$400(CandlepinPoolManager.java:73)
	at org.candlepin.controller.CandlepinPoolManager$NewHandler.handleSelfCertificate(CandlepinPoolManager.java:977)
	at org.candlepin.controller.CandlepinPoolManager.addOrUpdateEntitlement(CandlepinPoolManager.java:533)
	at org.candlepin.controller.CandlepinPoolManager.entitleByPool(CandlepinPoolManager.java:461)
	at com.google.inject.persist.jpa.JpaLocalTxnInterceptor.invoke(JpaLocalTxnInterceptor.java:66)
	at org.candlepin.controller.Entitler.createEntitlementByPool(Entitler.java:92)
	at org.candlepin.controller.Entitler.bindByPool(Entitler.java:84)
	at org.candlepin.controller.Entitler.bindByPool(Entitler.java:65)
	at org.candlepin.pinsetter.tasks.EntitlerJob.execute(EntitlerJob.java:60)
	... 3 more
Caused by: java.lang.IllegalArgumentException: string 1.3.6.1.4.1.2312.9.2.1952.null not an OID
	at org.bouncycastle.asn1.DERObjectIdentifier.<init>(Unknown Source)
	at org.bouncycastle.x509.X509V3CertificateGenerator.addExtension(Unknown Source)
	at org.candlepin.pki.impl.BouncyCastlePKIUtility.createX509Certificate(BouncyCastlePKIUtility.java:151)
	at org.candlepin.service.impl.DefaultEntitlementCertServiceAdapter.createX509Certificate(DefaultEntitlementCertServiceAdapter.java:182)
	at org.candlepin.service.impl.DefaultEntitlementCertServiceAdapter.generateEntitlementCert(DefaultEntitlementCertServiceAdapter.java:343)
	at org.candlepin.service.impl.DefaultEntitlementCertServiceAdapter.generateEntitlementCert(DefaultEntitlementCertServiceAdapter.java:112)
	at org.candlepin.controller.CandlepinPoolManager.generateEntitlementCertificate(CandlepinPoolManager.java:595)
	... 12 more
Comment 2 sthirugn@redhat.com 2013-08-22 12:04:56 EDT
Created attachment 789264 [details]
string 1.3.6.1.4.1.2312.9.2.1952.null not an OID error
Comment 4 Adrian Likins 2013-08-22 12:10:51 EDT
This seems like a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=997970
Comment 6 Adrian Likins 2013-08-22 12:35:51 EDT
(pondering...) I wonder if those ent certs being created as v1 is indicative of other problems in how those ents are created, and if that is causing manifest problems.
Comment 8 William Poteat 2013-08-23 14:31:23 EDT

*** This bug has been marked as a duplicate of bug 997970 ***

Note You need to log in before you can comment on or make changes to this bug.