Bug 1000103 - Zebra ZPL printers do not print bar codes without -o raw
Zebra ZPL printers do not print bar codes without -o raw
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cups (Show other bugs)
5.7
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Tim Waugh
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 13:01 EDT by Rene Feitelson
Modified: 2013-08-22 13:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-22 13:58:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Zebra printer bar code directives (894 bytes, text/plain)
2013-08-22 13:01 EDT, Rene Feitelson
no flags Details

  None (edit)
Description Rene Feitelson 2013-08-22 13:01:54 EDT
Created attachment 789277 [details]
Zebra printer bar code directives

Description of problem:  Zebra printer configured via CUPS as Zebra ZPL do not print bar codes correctly unless you send the output with -o raw option.  Without -o raw (or -oraw), the printer prints the ASCII control characters that are the ZPL bar code directives instead of the bar codes.  Workaround is to configure the Zebra printers as raw printers, rather than Zebra ZPL models.    


Version-Release number of selected component (if applicable):

# rpm -qa |grep cups
libgnomecups-0.2.2-9
cups-libs-1.3.7-30.el5_9.3
libgnomecups-0.2.2-9
cups-1.3.7-30.el5_9.3
cups-libs-1.3.7-30.el5_9.3
hal-cups-utils-0.6.2-5.2.el5

Zebra .ppd files:

# pwd
/usr/share/cups/model
# ll zebra*
-rw-r--r-- 1 root root  9568 Feb 25 11:14 zebracpl.ppd.gz
-rw-r--r-- 1 root root  8340 Feb 25 11:14 zebraep1.ppd.gz
-rw-r--r-- 1 root root  8920 Feb 25 11:14 zebraep2.ppd.gz
-rw-r--r-- 1 root root 18092 Feb 25 11:14 zebra.ppd.gz


How reproducible:  Send the attached file to a Zebra ZPL printer with, and without -o raw option.


Steps to Reproduce:
1.  Send attached file to Zebra ZPL printer without -o raw:  lp -d<printer>  <file> 
2.  Compare the results with -o raw:  lp -d<printer> -o raw <file>
3.

Actual results:


Expected results:  Zebra printers configured as Zebra ZPL printer in CUPS should print bar codes without -o raw on the lp command.


Additional info:
Comment 1 Jiri Popelka 2013-08-22 13:58:55 EDT
Thank you for the report, however
RHEL-5.10 (the next RHEL-5 minor release) is going to be the first production phase 2 [1] release of RHEL-5.
I'm closing this bugzilla as WONTFIX because since phase 2 we'll be addressing only security or critical issues.

[1] https://access.redhat.com/support/policy/updates/errata/

Note You need to log in before you can comment on or make changes to this bug.