Bug 1000104 - W2K8R2-SP1 fails 2 WHQL HCK tests
W2K8R2-SP1 fails 2 WHQL HCK tests
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: spice-qxl-driver-win (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: David Blechter
SPICE QE bug list
spice
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 13:08 EDT by Bill Sanford
Modified: 2016-02-10 15:21 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-09 16:23:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Spice
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the error message (856.17 KB, image/png)
2013-08-22 13:10 EDT, Bill Sanford
no flags Details

  None (edit)
Description Bill Sanford 2013-08-22 13:08:39 EDT
Description of problem:
Testing W2K8R2 SP1 with the new WHQL HCK studio results in two tests that fail. It is my understanding that the two test could be the same root cause and the one fix, will possibly fix both.

The error message in the command window is: 

Error: WDTF_PNP        : Result: Failed to recieve IRP_MN_REMOVE_DEVICE after receiving IRP_MN_SURPRISE_REMOVAL. Ensure that there are no open handlers or references to the test device (in user or kernel mode) preventing IRP_MN_REMOVE_DEVICE from being sent. You may need to terminate any processes or services that may have open user handles to this device.  ( 80004005 )

Version-Release number of selected component (if applicable):
Windows Server 2008 R2 SP1 (VM)
rhev-guest-tools-iso-3.3-3.noarch.rpm
qxl-win-unsigned-0.1-18

How reproducible:
100%

Steps to Reproduce:
1. Start the HCK test suite for QXL
2. Run 2089 Device Path Exerciser Test
3. Run 2079 Plug and Play Driver Test

Actual results:
Tests fail.

Expected results:
Tests pass.

Additional info:
Comment 1 Bill Sanford 2013-08-22 13:10:33 EDT
Created attachment 789279 [details]
Screenshot of the error message
Comment 2 David Blechter 2013-09-19 12:46:35 EDT
No HCK testing for 3.3, all qxl driver should pass WLK.

Moving to the future for now if we will switch to HCK
Comment 5 David Blechter 2015-09-09 16:23:50 EDT
no needs for keeping it for 2 years.

Note You need to log in before you can comment on or make changes to this bug.