Bug 1000118 - AHCI assignes ide-hd automatically only to the last bus (ahci.5)
AHCI assignes ide-hd automatically only to the last bus (ahci.5)
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 14:24 EDT by Lukas Doktor
Modified: 2013-08-31 11:05 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-31 11:05:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Doktor 2013-08-22 14:24:06 EDT
Description of problem:
Hi guys, when I add -device ahci, the following ide-hds are added automatically into ahci.5. In order to get more than one working disk I have to specify the bus=ahci.4 (3,2,1..).

Version-Release number of selected component (if applicable):
qemu-kvm-1.4.2-5.fc19.x86_64 (+ upstream 1.5.0)

How reproducible:
Always

Steps to Reproduce:
1. qemu-system-x86_64 -device ahci -drive id=aa,file=/tmp/asdf,if=none -drive id=bb,file=/tmp/asdf,if=none -device ide-hd,drive=aa -device ide-hd,drive=bb

Actual results:
qemu-system-x86_64: -device ide-hd,drive=bb: Can't create IDE unit 1, bus supports only 1 units
qemu-system-x86_64: -device ide-hd,drive=bb: Device initialization failed.
qemu-system-x86_64: -device ide-hd,drive=bb: Device 'ide-hd' could not be initialized


Expected results:
Assign the disks into the free IDE-compatible bus (ahci.4, ahci.3, ...)

Additional info:
When I explicitly specify the bus.port it works fine:
qemu-system-x86_64 -device ahci -drive id=aa,file=/tmp/asdf,if=none -drive id=bb,file=/tmp/asdf,if=none -device ide-hd,drive=aa -device ide-hd,drive=bb,bus=ahci.1
=> ahci.5 is taken by first ide-hd, ahci.1 by the second one.
Comment 1 Cole Robinson 2013-08-31 11:05:49 EDT
This is still relevant upstream, and since it's just a minor RFE I moved it to the upstream qemu tracker, please track progress there.

https://bugs.launchpad.net/qemu/+bug/1219234

Note You need to log in before you can comment on or make changes to this bug.