Bug 1000147 - Installing the candlepin cert rpm in the client does not update prefix field in /etc/rhsm/rhsm.conf
Installing the candlepin cert rpm in the client does not update prefix field ...
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
sthirugn@redhat.com
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-08-22 15:49 EDT by sthirugn@redhat.com
Modified: 2013-10-01 07:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:21:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sthirugn@redhat.com 2013-08-22 15:49:44 EDT
Description of problem:
Installing the candlepin cert rpm in the client does not update prefix field in /etc/rhsm/rhsm.conf

Version-Release number of selected component (if applicable):
* candlepin-0.8.20-1.el6sam.noarch
* candlepin-cert-consumer-cloud-qe-21.idm.lab.bos.redhat.com-1.0-1.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.20-1.el6sam.noarch
* candlepin-tomcat6-0.8.20-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-7.el6sat.noarch
* katello-cli-common-1.4.3-7.el6sat.noarch
* katello-common-1.4.3-8.el6sam_splice.noarch
* katello-configure-1.4.4-2.el6sat.noarch
* katello-glue-candlepin-1.4.3-8.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-8.el6sam_splice.noarch
* katello-headpin-1.4.3-8.el6sam_splice.noarch
* katello-headpin-all-1.4.3-8.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch


How reproducible:
Always

Steps to Reproduce:
1. Install SAM 1.3 server
2. In the client update /etc/rhsm/rhsm.conf from 
<SNIP>
# Server prefix:
prefix = /subscription
<SNIP>

to

<SNIP>
# Server prefix:
prefix = /
<SNIP>

3. Register this client to the SAM server from step 1
rpm -Uvh http://samserver/pub/candlepin-cert-consumer-latest.noarch.rpm

4. Check the client /etc/rhsm/rhsm.conf to see the Server hostname, Server port, base URL are all updated but the Server prefix field is not updated

Actual results:
Server prefix is still showing
<SNIP>
# Server prefix:
prefix = /
<SNIP>

Expected results:
<SNIP>
# Server prefix:
prefix = /subscription
<SNIP>

Additional info:
This is the behavior I found in the recent testing.  I am not sure if this is a bug or if it works as per design.  Please clarify.
Comment 1 Bryan Kearney 2013-08-30 16:07:22 EDT
commit 36ea4d5ba6f1b828b23313a725ceadaf59b0cded
Author: Bryan Kearney <bkearney@redhat.com>
Date:   Fri Aug 30 15:06:40 2013 -0400

    1000147: Set the url prefix in the subscription manager install script
Comment 3 sthirugn@redhat.com 2013-09-06 01:17:13 EDT
VERIFIED. The Server prefix is now updated.

# Server hostname:
hostname = host.redhat.com

# Server prefix:
prefix =/sam/api

# Server port:
port = 443


Version Tested:
* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-10.el6sat.noarch
* katello-cli-common-1.4.3-10.el6sat.noarch
* katello-common-1.4.3-12.el6sam_splice.noarch
* katello-configure-1.4.4-4.el6sat.noarch
* katello-glue-candlepin-1.4.3-12.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-12.el6sam_splice.noarch
* katello-headpin-1.4.3-12.el6sam_splice.noarch
* katello-headpin-all-1.4.3-12.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.34-1.el6sam.noarch
* thumbslug-selinux-0.0.34-1.el6sam.noarch
Comment 5 errata-xmlrpc 2013-10-01 07:21:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.