Bug 1000153 - availability graph isn't present unless there are other metrics
availability graph isn't present unless there are other metrics
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity high
: ---
: JON 3.2.1
Assigned To: Mike Thompson
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 16:08 EDT by Alan Santos
Modified: 2015-02-05 20:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-08 13:44:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
avail-graph.png (125.09 KB, image/png)
2013-09-19 11:50 EDT, Armine Hovsepyan
no flags Details
avail_group (210.00 KB, image/png)
2014-01-22 14:05 EST, Armine Hovsepyan
no flags Details

  None (edit)
Description Alan Santos 2013-08-22 16:08:21 EDT
Select a resource with no metrics - e.g. sudoers or bundle handler. 

Monitoring tab only contains 'schedules' there's no 'metrics' tab to view the avail graph.
Comment 1 Mike Thompson 2013-08-22 18:02:47 EDT
This was an oversight with combining the availability tab into the metrics tab. This has been fixed availability shows up even if the resource or resource group doesn't have metrics associated with it.

Committed to master: f8226ea.
Comment 2 Armine Hovsepyan 2013-09-19 11:50:33 EDT
Created attachment 800017 [details]
avail-graph.png
Comment 3 Armine Hovsepyan 2013-09-19 11:50:52 EDT
verified
Comment 4 Armine Hovsepyan 2013-11-26 07:50:02 EST
visible for resource groups in jon 3.2 er7 -> http://d.pr/i/Xha9
Comment 6 Mike Thompson 2014-01-22 10:45:58 EST
@Armine I think the comment https://bugzilla.redhat.com/show_bug.cgi?id=1000153#c4 is erroneous as the screen shot shows the group metrics page (which should not have the avail graph) and not group graphs page which does have the avail graph.

Please confirm.
Comment 7 Armine Hovsepyan 2014-01-22 13:41:08 EST
@Mike, I'm sorry, comment #4 is an invalid one. The screen-shot is on metrics page, while the issue is visible on graphs page.


Test scenario is the following:
go to platforms -> Storage Nodes group -> Graphs --- no availability graph visible
go to platforma -> CPUs -> graphs -- availability graph is visible
go to platforms -> CPUs -> graphs -> RHQ Storage Nodes group -> availability graph is visible
Comment 8 Armine Hovsepyan 2014-01-22 14:05:38 EST
Created attachment 854009 [details]
avail_group
Comment 9 Jay Shaughnessy 2014-01-23 13:38:47 EST
FYI: The fix for Bug 1057255 may be relevant.
Comment 10 Mike Thompson 2014-01-23 16:00:21 EST
Just FYI: this code was committed: 2013-08-22 18:02:47 EDT, was verified on 2013-09-19 11:50:52 EDT and made it to JON 3.2.0. release.

IMO the FailedQA on 2013-11-26 07:50:02 EST since it was already tested and committed to release/3.2.x. That is what changed the status to ASSIGNED from VERIFIED, which during a release can be very confusing.

I think we should split the bug from https://bugzilla.redhat.com/show_bug.cgi?id=1000153#c7 into its own BZ to avoid this confusion.
Comment 12 Armine Hovsepyan 2014-01-24 11:07:17 EST
original bug is verified in jon 3.2

separate bz for comment #7 filed -> #1057705
Comment 13 Mike Foley 2014-05-08 13:44:04 EDT
JON 3.2.1 released week of 5/5/2014

Note You need to log in before you can comment on or make changes to this bug.