Bug 1000210 - tvtime-scanner crashed with SIGSEGV in strncpy()
tvtime-scanner crashed with SIGSEGV in strncpy()
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tvtime (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Smetana
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 20:40 EDT by triniton
Modified: 2014-09-08 07:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-08 07:43:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[1] (46.03 KB, application/x-bzip)
2013-08-22 20:40 EDT, triniton
no flags Details
StacktraceSource (1.48 KB, text/plain)
2013-08-22 20:41 EDT, triniton
no flags Details

  None (edit)
Description triniton 2013-08-22 20:40:44 EDT
Created attachment 789406 [details]
[1]

Description of problem:


tvtime-scanner crashes with exit status 139.

The attachment [1] contains a testcase (under ./crash) crashing the
program. It ensures that you can easily reproduce the bug. Additionally,
under ./crash_info/, we include more information about the crash such as
a core dump, the dmesg generated by the crash, and its output.
Comment 1 triniton 2013-08-22 20:41:36 EDT
Created attachment 789407 [details]
StacktraceSource
Comment 2 POJAR GEORGE 2013-09-02 11:31:58 EDT
This seems to be the problem:
If env HOME unset(not empty), getenv("HOME") return NULL pointer and then causes strncpy() error.
Comment 3 Tomas Smetana 2013-09-03 03:10:34 EDT
Hi, thanks for the investigations.  I'll take a look at the crash.

Note You need to log in before you can comment on or make changes to this bug.