This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1000256 - mojomojo contains bundled Flash files
mojomojo contains bundled Flash files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mojomojo (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Iain Arnell
Fedora Extras Quality Assurance
:
Depends On: 1092015
Blocks: WebAssets-BundledBinaries
  Show dependency treegraph
 
Reported: 2013-08-23 00:29 EDT by T.C. Hollingsworth
Modified: 2014-07-02 09:57 EDT (History)
3 users (show)

See Also:
Fixed In Version: mojomojo-1.10-3.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 09:57:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description T.C. Hollingsworth 2013-08-23 00:29:28 EDT
This package contains binary files that are typically excuted by the Flash
player or another similar program.

These files are not permitted in Fedora. [1]  Everything we produce needs to
be built from source. [2]

The offending file(s) shipped in this package are:
/usr/share/mojomojo/root/static/flash/swfupload.swf
/usr/share/mojomojo/root/static/flash/swfupload_f8.swf
/usr/share/mojomojo/root/static/flash/swfupload_f9.swf

If these files are just a fallback for something that is now supported by modern
web standards like the HTML5 <video> element, please just remove the binaries.

If removing these files would seriously cripple your application, please let me
know so we can figure out a solution.

If you have any questions, please shout.  Thanks!

[1] https://fedoraproject.org/wiki/Packaging:Guidelines#No_inclusion_of_pre-built_binaries_or_libraries
[2] https://lists.fedoraproject.org/pipermail/devel/2013-August/187836.html
Comment 1 Iain Arnell 2013-09-20 12:38:41 EDT
swfupload can easily be removed, but I'm unable to rebuild at the minute due to a change in perl-Encode that is causing test failures.
Comment 2 Fedora Update System 2014-04-29 07:25:02 EDT
mojomojo-1.10-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mojomojo-1.10-3.fc20
Comment 3 Fedora Update System 2014-05-08 06:00:52 EDT
mojomojo-1.10-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.