Bug 1000287 - glib2 build error: Installed (but unpackaged) file(s) found
glib2 build error: Installed (but unpackaged) file(s) found
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glib2 (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Colin Walters
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 02:16 EDT by Tomas Pelka
Modified: 2013-11-21 00:29 EST (History)
0 users

See Also:
Fixed In Version: glib2-2.26.1-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 00:29:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Pelka 2013-08-23 02:16:46 EDT
Description of problem:
error: Installed (but unpackaged) file(s) found:
 /usr/share/systemtap/tapset/glib.stp
 /usr/share/systemtap/tapset/gobject.stp

Version-Release number of selected component (if applicable):
glib2-2.26.0-3.el6

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
unpackaged files

Expected results:
there should be no unpackaget files

Additional info:
Comment 1 Colin Walters 2013-08-27 09:27:13 EDT
Hm; I'm guessing something pulled systemtap into the buildroot since Matthew did the rebase here?  Regardless, the tap scrips to the best of my knowledge are not tested extensively in Fedora, so we should probably be conservative and not ship them in RHEL6.
Comment 2 Tomas Pelka 2013-08-27 09:36:19 EDT
(In reply to Colin Walters from comment #1)
> Hm; I'm guessing something pulled systemtap into the buildroot since Matthew
> did the rebase here?  Regardless, the tap scrips to the best of my knowledge
> are not tested extensively in Fedora, so we should probably be conservative
> and not ship them in RHEL6.

So shouldn't we just remove them in post phase?

Tom
Comment 4 Tomas Pelka 2013-08-27 10:06:41 EDT
Colin one more thought.

Seems these files are going to be created only in case is it build on system with SystemTap. Without it I believe they will not appear. So the configure script may automatically expect system without SystemTap.

That might cause confusion.

Tom
Comment 5 Colin Walters 2013-08-27 10:25:50 EDT
(In reply to Tomas Pelka from comment #4)
> Colin one more thought.
> 
> Seems these files are going to be created only in case is it build on system
> with SystemTap. Without it I believe they will not appear. So the configure
> script may automatically expect system without SystemTap.

The configure options should always win; if we say --disable-systemtap, it shouldn't complain at us if the buildroot happens to contain systemtap.  And that is how the code works.
Comment 6 Tomas Pelka 2013-08-27 10:30:59 EDT
Yes this is what I meant :D
Comment 10 errata-xmlrpc 2013-11-21 00:29:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1545.html

Note You need to log in before you can comment on or make changes to this bug.