Bug 1000317 - microcode update should be skipped in virtualized environment
microcode update should be skipped in virtualized environment
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: microcode_ctl (Show other bugs)
6.5
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Anton Arapov
Jeff Bastian
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 03:44 EDT by Chao Yang
Modified: 2014-06-18 04:03 EDT (History)
14 users (show)

See Also:
Fixed In Version: microcode_ctl-1.17-16.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 16:41:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch, update microcode on hosts only (1.17 KB, patch)
2013-08-23 06:57 EDT, Anton Arapov
no flags Details | Diff

  None (edit)
Description Chao Yang 2013-08-23 03:44:34 EDT
Description of problem:
Lots of failures was observed in guest dmesg. This didn't happen in host dmesg.

--- snip from guest dmesg ---
microcode: CPU0 sig=0x106a5, pf=0x1, revision=0x1
platform microcode: firmware: requesting intel-ucode/06-1a-05
microcode: CPU1 sig=0x106a5, pf=0x1, revision=0x1
platform microcode: firmware: requesting intel-ucode/06-1a-05
microcode: CPU2 sig=0x106a5, pf=0x1, revision=0x1
platform microcode: firmware: requesting intel-ucode/06-1a-05
microcode: CPU3 sig=0x106a5, pf=0x1, revision=0x1
platform microcode: firmware: requesting intel-ucode/06-1a-05
microcode: CPU4 sig=0x106a5, pf=0x1, revision=0x1
platform microcode: firmware: requesting intel-ucode/06-1a-05
microcode: CPU5 sig=0x106a5, pf=0x1, revision=0x1
platform microcode: firmware: requesting intel-ucode/06-1a-05
microcode: CPU6 sig=0x106a5, pf=0x1, revision=0x1
platform microcode: firmware: requesting intel-ucode/06-1a-05
microcode: CPU7 sig=0x106a5, pf=0x1, revision=0x1
platform microcode: firmware: requesting intel-ucode/06-1a-05
Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba
microcode: CPU0 update to revision 0x19 failed
microcode: CPU1 update to revision 0x19 failed
microcode: CPU2 update to revision 0x19 failed
microcode: CPU3 update to revision 0x19 failed
microcode: CPU4 update to revision 0x19 failed
microcode: CPU5 update to revision 0x19 failed
microcode: CPU6 update to revision 0x19 failed
microcode: CPU7 update to revision 0x19 failed
parport_pc 00:05: reported by Plug and Play ACPI
parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE]

--- snip from host dmesg ---
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU0 sig=0x106a5, pf=0x1, revision=0x11
Aug 20 17:24:27 intel-e5530-8-2 kernel: platform microcode: firmware: requesting intel-ucode/06-1a-05
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU1 sig=0x106a5, pf=0x1, revision=0x11
Aug 20 17:24:27 intel-e5530-8-2 kernel: platform microcode: firmware: requesting intel-ucode/06-1a-05
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU2 sig=0x106a5, pf=0x1, revision=0x11
Aug 20 17:24:27 intel-e5530-8-2 kernel: platform microcode: firmware: requesting intel-ucode/06-1a-05
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU3 sig=0x106a5, pf=0x1, revision=0x11
Aug 20 17:24:27 intel-e5530-8-2 kernel: platform microcode: firmware: requesting intel-ucode/06-1a-05
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU4 sig=0x106a5, pf=0x1, revision=0x11
Aug 20 17:24:27 intel-e5530-8-2 kernel: platform microcode: firmware: requesting intel-ucode/06-1a-05
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU5 sig=0x106a5, pf=0x1, revision=0x11
Aug 20 17:24:27 intel-e5530-8-2 kernel: platform microcode: firmware: requesting intel-ucode/06-1a-05
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU6 sig=0x106a5, pf=0x1, revision=0x11
Aug 20 17:24:27 intel-e5530-8-2 kernel: platform microcode: firmware: requesting intel-ucode/06-1a-05
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU7 sig=0x106a5, pf=0x1, revision=0x11
Aug 20 17:24:27 intel-e5530-8-2 kernel: platform microcode: firmware: requesting intel-ucode/06-1a-05
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU8 sig=0x106a5, pf=0x1, revision=0x11
Aug 20 17:24:27 intel-e5530-8-2 kernel: platform microcode: firmware: requesting intel-ucode/06-1a-05
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU9 sig=0x106a5, pf=0x1, revision=0x11
Aug 20 17:24:27 intel-e5530-8-2 kernel: platform microcode: firmware: requesting intel-ucode/06-1a-05
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU10 sig=0x106a5, pf=0x1, revision=0x11
Aug 20 17:24:27 intel-e5530-8-2 kernel: platform microcode: firmware: requesting intel-ucode/06-1a-05
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU11 sig=0x106a5, pf=0x1, revision=0x11
Aug 20 17:24:27 intel-e5530-8-2 kernel: platform microcode: firmware: requesting intel-ucode/06-1a-05
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU12 sig=0x106a5, pf=0x1, revision=0x11
Aug 20 17:24:27 intel-e5530-8-2 kernel: platform microcode: firmware: requesting intel-ucode/06-1a-05
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU13 sig=0x106a5, pf=0x1, revision=0x11
Aug 20 17:24:27 intel-e5530-8-2 kernel: platform microcode: firmware: requesting intel-ucode/06-1a-05
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU14 sig=0x106a5, pf=0x1, revision=0x11
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU15 sig=0x106a5, pf=0x1, revision=0x11
Aug 20 17:24:27 intel-e5530-8-2 kernel: platform microcode: firmware: requesting intel-ucode/06-1a-05
Aug 20 17:24:27 intel-e5530-8-2 kernel: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU0 updated to revision 0x19, date = 2013-06-21
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU1 updated to revision 0x19, date = 2013-06-21
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU2 updated to revision 0x19, date = 2013-06-21
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU3 updated to revision 0x19, date = 2013-06-21
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU4 updated to revision 0x19, date = 2013-06-21
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU5 updated to revision 0x19, date = 2013-06-21
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU6 updated to revision 0x19, date = 2013-06-21
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU7 updated to revision 0x19, date = 2013-06-21
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU8 updated to revision 0x19, date = 2013-06-21
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU9 updated to revision 0x19, date = 2013-06-21
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU10 updated to revision 0x19, date = 2013-06-21
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU11 updated to revision 0x19, date = 2013-06-21
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU12 updated to revision 0x19, date = 2013-06-21
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU13 updated to revision 0x19, date = 2013-06-21
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU14 updated to revision 0x19, date = 2013-06-21
Aug 20 17:24:27 intel-e5530-8-2 kernel: microcode: CPU15 updated to revision 0x19, date = 2013-06-21
Aug 20 17:24:27 intel-e5530-8-2 kernel: kvm: VM_EXIT_LOAD_IA32_PERF_GLOBAL_CTRL does not work properly. Using workaround


Version-Release number of selected component (if applicable):
2.6.32-414.el6.x86_64
qemu-kvm-0.12.1.2-2.397.el6.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
This log is a little different from Bug 860929 - microcode: CPUx: update failed (for patch_level=0x6000624)
Comment 2 Paolo Bonzini 2013-08-23 04:31:01 EDT
Microcode_ctl should detect hypervisor presence (execute CPUID with EAX=1, check bit 31 of ECX on output), and skip hypervisor updates if so.
Comment 3 Anton Arapov 2013-08-23 06:57:25 EDT
Created attachment 789554 [details]
patch, update microcode on hosts only

This should do the trick.
Comment 4 Anton Arapov 2013-08-23 07:00:06 EDT
I don't mind push it. It is also easy for QA to test.

Taking schedule into account, one should bother with blocker flag if he wants it in RHEL 6.5
Comment 18 errata-xmlrpc 2013-11-21 16:41:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1668.html

Note You need to log in before you can comment on or make changes to this bug.