Bug 1000341 - Adding info about migration of remote clients using JNDI for invoking EJB
Adding info about migration of remote clients using JNDI for invoking EJB
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: sgilda
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 04:57 EDT by Ondrej Chaloupka
Modified: 2014-08-14 11:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build: CSProcessor Builder Version 1.13 Build Name: 19236, Migration Guide-6.1.1-1 Build Date: 23-08-2013 13:02:05 Topic ID: 5419-499807 [Specified]
Last Closed: 2013-08-23 08:23:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Chaloupka 2013-08-23 04:57:22 EDT
Title: Portable EJB JNDI Names

Hi,

in my opinion it would be fine to have a new sub-chapter about EJB invocations from remote client. There was change in assembling the JNDI name from something like
MyBean/remote in EAP5
to
ejb:/nameofjar/MyBean!my.app.MyBeanRemote in EAP6

Info about the current state could be found at
https://docs.jboss.org/author/display/AS71/EJB+invocations+from+a+remote+client+using+JNDI

Ondra
Comment 1 sgilda 2013-08-23 08:14:13 EDT
Does the section on 'Remote Invocation Changes' address the cliet remote EJB lookup changes? 

http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_JBoss_Enterprise_Application_Platform/6.1.1/html-single/Migration_Guide/index.html#sect-Remote_Invocation_Changes

I worked very closely with Jaikiran on that section using the link you provided above. 

If this is not what you are looking for, could you be specific about what is missing?
Comment 2 Ondrej Chaloupka 2013-08-23 08:23:25 EDT
Ouch, it's what I was looking for. I was looking around the EJB chapter but strangly I didn't hit it.
Sorry, closing as not a bug.

Note You need to log in before you can comment on or make changes to this bug.